summaryrefslogtreecommitdiffstats
path: root/boot/grub2/grub2.mk
diff options
context:
space:
mode:
Diffstat (limited to 'boot/grub2/grub2.mk')
-rw-r--r--boot/grub2/grub2.mk27
1 files changed, 0 insertions, 27 deletions
diff --git a/boot/grub2/grub2.mk b/boot/grub2/grub2.mk
index 95fa24503..6c3bbefe3 100644
--- a/boot/grub2/grub2.mk
+++ b/boot/grub2/grub2.mk
@@ -18,39 +18,12 @@ GRUB2_SITE=$(BR2_DEBIAN_MIRROR)/debian/pool/main/g/grub2
GRUB2_PATCH_SITE:=$(GRUB2_SITE)
GRUB2_CAT:=$(ZCAT)
GRUB2_DIR:=$(BUILD_DIR)/grub-1.98
-GRUB2_BINARY:=grub2/grub2
-GRUB2_TARGET_BINARY:=sbin/grub2
-GRUB2_SPLASHIMAGE=$(TOPDIR)/boot/grub/splash.xpm.gz
GRUB2_CFLAGS=-DSUPPORT_LOOPDEV
ifeq ($(BR2_LARGEFILE),)
GRUB2_CFLAGS+=-U_FILE_OFFSET_BITS
endif
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_SPLASH) += --enable-graphics
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_DISKLESS) += --enable-diskless
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_3c595) += --enable-3c595
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_3c90x) += --enable-3c90x
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_davicom) += --enable-davicom
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_e1000) += --enable-e1000
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_eepro100) += --enable-eepro100
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_epic100) += --enable-epic100
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_forcedeth) += --enable-forcedeth
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_natsemi) += --enable-natsemi
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_ns83820) += --enable-ns83820
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_ns8390) += --enable-ns8390
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_pcnet32) += --enable-pcnet32
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_pnic) += --enable-pnic
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_rtl8139) += --enable-rtl8139
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_r8169) += --enable-r8169
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_sis900) += --enable-sis900
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_tg3) += --enable-tg3
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_tulip) += --enable-tulip
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_tlan) += --enable-tlan
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_undi) += --enable-undi
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_via_rhine) += --enable-via-rhine
-GRUB2_CONFIG-$(BR2_TARGET_GRUB2_w89c840) += --enable-w89c840
-
$(DL_DIR)/$(GRUB2_SOURCE):
$(call DOWNLOAD,$(GRUB2_SITE),$(GRUB2_SOURCE))