summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 19bb5eb91..45e2f2f96 100644
--- a/Makefile
+++ b/Makefile
@@ -201,10 +201,12 @@ TARGETS+=ext2root
#############################################################
ifeq ($(SOFT_FLOAT),true)
-SOFT_FLOAT_CONFIG_OPTION=--without-float
-TARGET_SOFT_FLOAT=-msoft-float
+SOFT_FLOAT_CONFIG_OPTION:=--without-float
+TARGET_SOFT_FLOAT:=-msoft-float
ARCH_FPU_SUFFIX:=_nofpu
else
+SOFT_FLOAT_CONFIG_OPTION:=
+TARGET_SOFT_FLOAT:=
ARCH_FPU_SUFFIX:=
endif