diff options
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 11 |
1 files changed, 11 insertions, 0 deletions
@@ -78,6 +78,11 @@ CONFIG_SHELL:=$(shell if [ -x "$$BASH" ]; then echo $$BASH; \ export CONFIG_SHELL quiet Q KBUILD_VERBOSE VERBOSE +HOSTCCACHE:=$(shell $(CONFIG_SHELL) -c "which ccache") +ifneq ($(HOSTCCACHE),) +BR2_HAVE_HOST_CCACHE=y +endif + ifndef HOSTAR HOSTAR:=ar endif @@ -124,6 +129,12 @@ endif ifndef FCFLAGS_FOR_BUILD FCFLAGS_FOR_BUILD:=-g -O2 endif + +ifeq ($(BR2_HAVE_HOST_CCACHE),y) +HOSTCC:=$(HOSTCCACHE) $(HOSTCC) +HOSTCXX:=$(HOSTCCACHE) $(HOSTCXX) +endif + export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTFC HOSTLD |