summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--boot/at91dataflashboot/at91dataflashboot.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/boot/at91dataflashboot/at91dataflashboot.mk b/boot/at91dataflashboot/at91dataflashboot.mk
index d11f842d8..32591f79f 100644
--- a/boot/at91dataflashboot/at91dataflashboot.mk
+++ b/boot/at91dataflashboot/at91dataflashboot.mk
@@ -16,11 +16,12 @@ $(DL_DIR)/$(DATAFLASHBOOT_SOURCE):
$(DATAFLASHBOOT_DIR)/.unpacked: $(DL_DIR)/$(DATAFLASHBOOT_SOURCE)
mkdir -p $(@D)
$(BZCAT) $(DL_DIR)/$(DATAFLASHBOOT_SOURCE) | tar $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
- touch $(DATAFLASHBOOT_DIR)/.unpacked
+ touch $@
$(DATAFLASHBOOT_DIR)/.patched: $(DATAFLASHBOOT_DIR)/.unpacked
toolchain/patch-kernel.sh $(@D) boot/at91dataflashboot \
at91dataflashboot-$(DATAFLASHBOOT_VERSION)-\*.patch
+ touch $@
$(DATAFLASHBOOT_DIR)/$(DATAFLASHBOOT_BINARY): $(DATAFLASHBOOT_DIR)/.patched
ls $(DATAFLASHBOOT_DIR)/.unpacked