summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xpackage/acpid/S02acpid22
-rw-r--r--package/acpid/acpid.mk1
2 files changed, 23 insertions, 0 deletions
diff --git a/package/acpid/S02acpid b/package/acpid/S02acpid
new file mode 100755
index 000000000..ec686d8f5
--- /dev/null
+++ b/package/acpid/S02acpid
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+case "$1" in
+ start)
+ echo -n "Starting acpid: "
+ start-stop-daemon -S -q -m -b -p /var/run/acpid.pid --exec /usr/sbin/acpid -- -n
+ echo "done"
+ ;;
+ stop)
+ echo -n "Stopping acpid: "
+ start-stop-daemon -K -q -p /var/run/acpid.pid
+ echo "done"
+ ;;
+ restart)
+ "$0" stop
+ sleep 1
+ "$0" start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ ;;
+esac
diff --git a/package/acpid/acpid.mk b/package/acpid/acpid.mk
index cacfb27e7..56f671d99 100644
--- a/package/acpid/acpid.mk
+++ b/package/acpid/acpid.mk
@@ -18,6 +18,7 @@ define ACPID_INSTALL_TARGET_CMDS
install -D -m 644 $(@D)/acpi_listen.8 $(TARGET_DIR)/usr/share/man/man8/acpi_listen.8
mkdir -p $(TARGET_DIR)/etc/acpi/events
/bin/echo -e "event=button[ /]power\naction=/sbin/poweroff" > $(TARGET_DIR)/etc/acpi/events/powerbtn
+ $(INSTALL) -D -m 0755 package/acpid/S02acpid $(TARGET_DIR)/etc/init.d/S02acpid
endef
define ACPID_UNINSTALL_TARGET_CMDS