summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--make/user-mode-linux.mk5
-rw-r--r--sources/linux-uml.config16
2 files changed, 17 insertions, 4 deletions
diff --git a/make/user-mode-linux.mk b/make/user-mode-linux.mk
index 331391278..7315307be 100644
--- a/make/user-mode-linux.mk
+++ b/make/user-mode-linux.mk
@@ -5,11 +5,11 @@
#############################################################
ifneq ($(filter $(TARGETS),user-mode-linux),)
-LINUX_VERSION=2.4.19
+LINUX_VERSION=2.4.20
LINUX_DIR=$(BUILD_DIR)/linux-$(LINUX_VERSION)
LINUX_SOURCE=linux-$(LINUX_VERSION).tar.bz2
LINUX_SITE=http://ftp.us.kernel.org/pub/linux/kernel/v2.4
-LINUX_PATCH_1:=uml-patch-$(LINUX_VERSION)-45.bz2
+LINUX_PATCH_1:=uml-patch-$(LINUX_VERSION)-5.bz2
LINUX_PATCH_1_SITE:=http://telia.dl.sourceforge.net/sourceforge/user-mode-linux
LINUX_KCONFIG=$(SOURCE_DIR)/linux-uml.config
LINUX_KERNEL=$(BASE_DIR)/UMlinux
@@ -26,6 +26,7 @@ user-mode-linux-source: $(DL_DIR)/$(LINUX_SOURCE) $(DL_DIR)/$(LINUX_PATCH_1)
$(LINUX_DIR)/.unpacked: $(DL_DIR)/$(LINUX_SOURCE) $(DL_DIR)/$(LINUX_PATCH_1)
bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ rm -rf $(BUILD_DIR)/linux
-(cd $(BUILD_DIR); ln -sf $(LINUX_DIR) linux)
touch $(LINUX_DIR)/.unpacked
diff --git a/sources/linux-uml.config b/sources/linux-uml.config
index 25fcf481d..c949a959b 100644
--- a/sources/linux-uml.config
+++ b/sources/linux-uml.config
@@ -16,8 +16,8 @@ CONFIG_EXPERIMENTAL=y
#
# General Setup
#
-CONFIG_MODE_TT=y
CONFIG_MODE_SKAS=y
+CONFIG_MODE_TT=y
CONFIG_NET=y
CONFIG_SYSVIPC=y
# CONFIG_BSD_PROCESS_ACCT is not set
@@ -177,6 +177,8 @@ CONFIG_INET=y
# CONFIG_ADFS_FS_RW is not set
# CONFIG_AFFS_FS is not set
# CONFIG_HFS_FS is not set
+# CONFIG_BEFS_FS is not set
+# CONFIG_BEFS_DEBUG is not set
# CONFIG_BFS_FS is not set
CONFIG_EXT3_FS=y
CONFIG_JBD=y
@@ -194,6 +196,9 @@ CONFIG_RAMFS=y
# CONFIG_ISO9660_FS is not set
# CONFIG_JOLIET is not set
# CONFIG_ZISOFS is not set
+# CONFIG_JFS_FS is not set
+# CONFIG_JFS_DEBUG is not set
+# CONFIG_JFS_STATISTICS is not set
CONFIG_MINIX_FS=y
# CONFIG_VXFS_FS is not set
# CONFIG_NTFS_FS is not set
@@ -224,6 +229,7 @@ CONFIG_NFS_V3=y
# CONFIG_ROOT_NFS is not set
# CONFIG_NFSD is not set
# CONFIG_NFSD_V3 is not set
+# CONFIG_NFSD_TCP is not set
CONFIG_SUNRPC=y
CONFIG_LOCKD=y
CONFIG_LOCKD_V4=y
@@ -238,7 +244,6 @@ CONFIG_LOCKD_V4=y
# CONFIG_NCPFS_NLS is not set
# CONFIG_NCPFS_EXTRAS is not set
# CONFIG_ZISOFS_FS is not set
-CONFIG_ZLIB_FS_INFLATE=y
#
# Partition Types
@@ -259,6 +264,7 @@ CONFIG_LDM_PARTITION=y
CONFIG_SGI_PARTITION=y
CONFIG_ULTRIX_PARTITION=y
CONFIG_SUN_PARTITION=y
+# CONFIG_EFI_PARTITION is not set
# CONFIG_SMB_NLS is not set
CONFIG_NLS=y
@@ -327,6 +333,12 @@ CONFIG_NLS_UTF8=m
# CONFIG_MTD is not set
#
+# Library routines
+#
+CONFIG_ZLIB_INFLATE=y
+CONFIG_ZLIB_DEFLATE=y
+
+#
# Kernel hacking
#
# CONFIG_DEBUG_SLAB is not set