aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Makefile.autotools.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 8294ebfa6..076006300 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -125,7 +125,7 @@ TAR ?= tar
# ACLOCAL="$(ACLOCAL)"
# Automatically detect tar --strip-path/components option
-TAR_STRIP_COMPONENTS = $(shell tar --help | grep strip-path > /dev/null ; if test $$? = 0 ; then echo '--strip-path' ; else echo '--strip-components' ; fi)
+TAR_STRIP_COMPONENTS := $(shell $(CONFIG_SHELL) -c '$(TAR) --help | grep strip-path > /dev/null ; if test $$? = 0 ; then echo '--strip-path' ; else echo '--strip-components' ; fi')
################################################################################
# Implicit targets -- produce a stamp file for each step of a package build