aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/busybox/Config.in11
-rw-r--r--package/busybox/busybox.mk30
2 files changed, 13 insertions, 28 deletions
diff --git a/package/busybox/Config.in b/package/busybox/Config.in
index 88d54fba2..f04f34fb6 100644
--- a/package/busybox/Config.in
+++ b/package/busybox/Config.in
@@ -12,7 +12,7 @@ config BR2_PACKAGE_BUSYBOX
choice
prompt "BusyBox Version"
depends BR2_PACKAGE_BUSYBOX
- default BR2_BUSYBOX_VERSION_1_2_2_1
+ default BR2_BUSYBOX_VERSION_1_4_2
help
Select the version of BusyBox you wish to use.
@@ -26,6 +26,7 @@ choice
config BR2_BUSYBOX_VERSION_1_2_2_1
bool "BusyBox 1.2.2.1"
+ depends on BR2_DEPRECATED
config BR2_BUSYBOX_VERSION_1_4_0
bool "BusyBox 1.4.0"
@@ -43,6 +44,14 @@ choice
endchoice
+config BR2_BUSYBOX_VERSION
+ string
+ default "1.0.1" if BR2_BUSYBOX_VERSION_1_0_1
+ default "1.1.3" if BR2_BUSYBOX_VERSION_1_1_3
+ default "1.2.2.1" if BR2_BUSYBOX_VERSION_1_2_2_1
+ default "1.4.0" if BR2_BUSYBOX_VERSION_1_4_0
+ default "1.4.1" if BR2_BUSYBOX_VERSION_1_4_1
+ default "1.4.2" if BR2_BUSYBOX_VERSION_1_4_2
config BR2_PACKAGE_BUSYBOX_INSTALL_SYMLINKS
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 1574e9a50..3d350a794 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -4,30 +4,6 @@
#
#############################################################
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_0_1)),y)
-BUSYBOX_VER:=1.01
-endif
-
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_1_3)),y)
-BUSYBOX_VER:=1.1.3
-endif
-
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_2_2_1)),y)
-BUSYBOX_VER:=1.2.2.1
-endif
-
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_4_0)),y)
-BUSYBOX_VER:=1.4.0
-endif
-
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_4_1)),y)
-BUSYBOX_VER:=1.4.1
-endif
-
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_4_2)),y)
-BUSYBOX_VER:=1.4.2
-endif
-
ifeq ($(strip $(BR2_PACKAGE_BUSYBOX_SNAPSHOT)),y)
# Be aware that this changes daily....
@@ -35,8 +11,8 @@ BUSYBOX_DIR:=$(BUILD_DIR)/busybox
BUSYBOX_SOURCE:=busybox-snapshot.tar.bz2
BUSYBOX_SITE:=http://www.busybox.net/downloads/snapshots
else
-BUSYBOX_DIR:=$(BUILD_DIR)/busybox-$(BUSYBOX_VER)
-BUSYBOX_SOURCE:=busybox-$(BUSYBOX_VER).tar.bz2
+BUSYBOX_DIR:=$(BUILD_DIR)/busybox-$(BR2_BUSYBOX_VERSION)
+BUSYBOX_SOURCE:=busybox-$(BR2_BUSYBOX_VERSION).tar.bz2
BUSYBOX_SITE:=http://www.busybox.net/downloads
endif
@@ -62,7 +38,7 @@ endif
ifeq ($(strip $(BR2_PACKAGE_BUSYBOX_SNAPSHOT)),y)
toolchain/patch-kernel.sh $(BUSYBOX_DIR) package/busybox busybox.\*.patch
else
- toolchain/patch-kernel.sh $(BUSYBOX_DIR) package/busybox busybox-$(BUSYBOX_VER)-\*.patch
+ toolchain/patch-kernel.sh $(BUSYBOX_DIR) package/busybox busybox-$(BR2_BUSYBOX_VERSION)-\*.patch
endif
touch $@