diff options
-rw-r--r-- | CHANGES | 1 | ||||
-rw-r--r-- | boot/grub/grub.mk | 2 | ||||
-rwxr-xr-x | support/scripts/apply-patches.sh | 2 |
3 files changed, 3 insertions, 2 deletions
@@ -11,6 +11,7 @@ Issues resolved (http://bugs.uclibc.org): + #4357: Prevent patch commands from accessing source control #4369: Fix permissions on untared lsof archive 2011.11-rc2, Released November 18th, 2011: diff --git a/boot/grub/grub.mk b/boot/grub/grub.mk index fbff86711..1b5ca0dd2 100644 --- a/boot/grub/grub.mk +++ b/boot/grub/grub.mk @@ -41,7 +41,7 @@ GRUB_CONFIG-$(BR2_TARGET_GRUB_w89c840) += --enable-w89c840 define GRUB_DEBIAN_PATCHES # Apply the patches from the Debian patch (cd $(@D) ; for f in `cat debian/patches/00list | grep -v ^#` ; do \ - cat debian/patches/$$f | patch -p1 ; \ + cat debian/patches/$$f | patch -g0 -p1 ; \ done) endef diff --git a/support/scripts/apply-patches.sh b/support/scripts/apply-patches.sh index 76cb9f753..1aef47ebf 100755 --- a/support/scripts/apply-patches.sh +++ b/support/scripts/apply-patches.sh @@ -21,7 +21,7 @@ if [ ! -d "${patchdir}" ] ; then fi for i in `cd ${patchdir}; ls -d ${patchpattern} 2> /dev/null` ; do - apply="patch -p1 -E -d" + apply="patch -g0 -p1 -E -d" uncomp_parm="" if [ -d "${patchdir}/$i" ] ; then type="directory overlay" |