diff options
-rw-r--r-- | Makefile | 13 |
1 files changed, 12 insertions, 1 deletions
@@ -202,7 +202,18 @@ include project/*.mk # in the .config file. ifeq ($(BR2_TOOLCHAIN_SOURCE),y) # avoid pulling in external toolchain which is broken for toplvl parallel builds -include $(filter-out $(wildcard toolchain/external-toolchain/*),$(wildcard toolchain/*/*.mk)) +# Explicit ordering: +include toolchain/dependencies/dependencies.mk +include toolchain/binutils/binutils.mk +include toolchain/ccache/ccache.mk +include toolchain/elf2flt/elf2flt.mk +include toolchain/gcc/gcc-uclibc-3.x.mk +include toolchain/gcc/gcc-uclibc-4.x.mk +include toolchain/gdb/gdb.mk +include toolchain/kernel-headers/kernel-headers.mk +include toolchain/mklibs/mklibs.mk +include toolchain/sstrip/sstrip.mk +include toolchain/uClibc/uclibc.mk else include toolchain/*/*.mk endif |