summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/cloop/cloop.mk1
-rw-r--r--target/ext2/ext2root.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/target/cloop/cloop.mk b/target/cloop/cloop.mk
index 8484ffedd..ca6d8bd4a 100644
--- a/target/cloop/cloop.mk
+++ b/target/cloop/cloop.mk
@@ -77,6 +77,7 @@ clooproot: cloop check-tools $(IMAGE).cramfs ### cramfsroot
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/share/man
@rm -rf $(TARGET_DIR)/usr/info
+ @rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share
### $(CLOOP_DIR)/create_compressed_fs -q -D target/default/device_table.txt $(TARGET_DIR) $(IMAGE).cloop
## mkisofs -r $(TARGET_DIR) | $(CLOOP_DIR)/create_compressed_fs - 65536 > $(IMAGE).cloop
sudo /sbin/losetup -d /dev/loop1
diff --git a/target/ext2/ext2root.mk b/target/ext2/ext2root.mk
index 600cf134b..08a407eab 100644
--- a/target/ext2/ext2root.mk
+++ b/target/ext2/ext2root.mk
@@ -91,6 +91,7 @@ $(EXT2_BASE): host-fakeroot makedevs genext2fs
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/share/man
@rm -rf $(TARGET_DIR)/usr/info
+ @rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share
-/sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(STAGING_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))