summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/qtopia4/qtopia4.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index c959d4001..360b9492e 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -253,10 +253,15 @@ endif
-[ -f $(QTOPIA4_QCONFIG_FILE) ] && cp $(QTOPIA4_QCONFIG_FILE) \
$(QTOPIA4_TARGET_DIR)/$(QTOPIA4_QCONFIG_FILE_LOCATION)
+# Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.
+# PKG_CONFIG_SYSROOT is only used to avoid a warning from Qt's configure system
+# when cross compiling, Qt 4.4.3 is wrong here.
(cd $(QTOPIA4_TARGET_DIR); rm -rf config.cache; \
- PATH=$(TARGET_PATH) \
+ $(TARGET_CONFIGURE_OPTS) \
+ PKG_CONFIG_SYSROOT="$(STAGING_DIR)" \
./configure \
-verbose \
+ -force-pkg-config \
-embedded $(BR2_PACKAGE_QTOPIA4_EMB_PLATFORM) \
$(QTOPIA4_QCONFIG_COMMAND) \
$(QTOPIA4_CONFIGURE) \