summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorDavid Anders <dave123@abcsinc.com>2006-01-19 13:29:23 +0000
committerDavid Anders <dave123@abcsinc.com>2006-01-19 13:29:23 +0000
commit64c3f9b0e87be53a0d5dea71f2565234814b1b0f (patch)
tree52f723f0ea55145b9117ae69789b8a9985b738fb /toolchain
parent59af097dd97ade5d5337e4407d31d552a92d3f0e (diff)
downloadbuildroot-novena-64c3f9b0e87be53a0d5dea71f2565234814b1b0f.tar.gz
buildroot-novena-64c3f9b0e87be53a0d5dea71f2565234814b1b0f.zip
added arm variant selection
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/uclibc.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 700b9d618..ace8f55df 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -78,6 +78,10 @@ $(UCLIBC_DIR)/.configured: $(UCLIBC_DIR)/.unpacked
-e 's,^DEVEL_PREFIX=.*,DEVEL_PREFIX=\"/usr/\",g' \
-e 's,^SHARED_LIB_LOADER_PREFIX=.*,SHARED_LIB_LOADER_PREFIX=\"/lib\",g' \
$(UCLIBC_DIR)/.config
+ifeq ($(BR2_ARCH),"arm")
+ $(SED) 's,^.*CONFIG_$(shell echo $(BR2_ARM_TYPE)).*,CONFIG_$(shell echo $(BR2_ARM_TYPE))=y,g' \
+ $(UCLIBC_DIR)/.config
+endif
ifneq ($(UCLIBC_TARGET_ENDIAN),)
$(SED) '/^# ARCH_$(UCLIBC_TARGET_ENDIAN)_ENDIAN /{s,# ,,;s, is not set,=y,g}' \
-e '/^# ARCH_$(UCLIBC_NOT_TARGET_ENDIAN)_ENDIAN /{s,# ,,;s, is not set,=n,g}' \