summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-03-02 07:07:22 +0000
committerEric Andersen <andersen@codepoet.org>2005-03-02 07:07:22 +0000
commite076bd4b3392bf429e16aab1fa1711fab6f345c9 (patch)
treeaf1c7e954f785aca0e6b08aca63c57de263f9414 /toolchain
parent8855700d8355773ad7ae1ea1bfebaf307d190349 (diff)
downloadbuildroot-novena-e076bd4b3392bf429e16aab1fa1711fab6f345c9.tar.gz
buildroot-novena-e076bd4b3392bf429e16aab1fa1711fab6f345c9.zip
teach BR2_INSTALL_LIBSTDCPP to actually install libstdc++
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk17
1 files changed, 12 insertions, 5 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 0e400c236..fd084b29b 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -49,10 +49,6 @@ TARGET_LANGUAGES:=c
endif
endif
-ifeq ($(BR2_INSTALL_OBJC),y)
-TARGET_LANGUAGES:=$(TARGET_LANGUAGES),objc
-endif
-
#############################################################
#
# build the first pass gcc compiler
@@ -136,7 +132,7 @@ gcc_initial-dirclean:
#############################################################
#
-# second pass compiler build. Build the compiler targeting
+# second pass compiler build. Build the compiler targeting
# the newly built shared uClibc library.
#
#############################################################
@@ -219,6 +215,17 @@ $(TARGET_DIR)/lib/libgcc_s.so.1: $(GCC_BUILD_DIR2)/.installed
rm -rf $(TARGET_DIR)/usr/lib/libgcc_s.so*
-$(STRIP) $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s.so.1
-cp -a $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s* $(TARGET_DIR)/lib/
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+ -cp -a $(STAGING_DIR)/lib/libstdc++.so* $(TARGET_DIR)/lib/
+endif
+ifeq ($(BR2_INSTALL_LIBGCJ),y)
+ -cp -a $(STAGING_DIR)/lib/libgcj.so* $(TARGET_DIR)/lib/
+ -cp -a $(STAGING_DIR)/lib/lib-org-w3c-dom.so* $(TARGET_DIR)/lib/
+ -cp -a $(STAGING_DIR)/lib/lib-org-xml-sax.so* $(TARGET_DIR)/lib/
+ -mkdir -p $(TARGET_DIR)/usr/lib/security
+ -cp -a $(STAGING_DIR)/usr/lib/security/libgcj.security $(TARGET_DIR)/usr/lib/security/
+ -cp -a $(STAGING_DIR)/usr/lib/security/classpath.security $(TARGET_DIR)/usr/lib/security/
+endif
gcc: uclibc-configured binutils gcc_initial $(LIBFLOAT_TARGET) uclibc \
$(TARGET_DIR)/lib/libgcc_s.so.1 $(GCC_BUILD_DIR2)/.installed $(GCC_TARGETS)