summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-21 10:28:43 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-21 10:28:43 +0000
commit3539f8a9d1a5b1e084d43944e213488fe3ad83f2 (patch)
treeebe3beb03e7865d5ccf6d590a1416948b4cf7dcb /toolchain
parentdf7222a2e5dd03b74d76ef9a64bfc9a860987843 (diff)
downloadbuildroot-novena-3539f8a9d1a5b1e084d43944e213488fe3ad83f2.tar.gz
buildroot-novena-3539f8a9d1a5b1e084d43944e213488fe3ad83f2.zip
- put libstdc++.so into the correct place (usr/lib) and make sure that the dir exists
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk1
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk3
2 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 798ba25b9..48f6ace69 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -309,6 +309,7 @@ endif
#
# Ok... that's enough of that.
#
+ -mkdir -p $(TARGET_DIR)/usr/lib $(TARGET_DIR)/usr/sbin
touch $@
$(GCC_BUILD_DIR2)/.libs_installed: $(GCC_BUILD_DIR2)/.installed
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 0001de836..48446a4b0 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -333,6 +333,7 @@ endif
#
# Ok... that's enough of that.
#
+ -mkdir -p $(TARGET_DIR)/usr/lib $(TARGET_DIR)/usr/sbin
touch $@
$(GCC_BUILD_DIR2)/.libs_installed: $(GCC_BUILD_DIR2)/.installed
@@ -342,7 +343,7 @@ ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
-cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s* $(TARGET_DIR)/lib/
endif
ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
- -cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libstdc++.so* $(TARGET_DIR)/lib/
+ -cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libstdc++.so* $(TARGET_DIR)/usr/lib/
endif
ifeq ($(BR2_INSTALL_LIBGCJ),y)
-cp -dpf $(STAGING_DIR)/lib/libgcj.so* $(TARGET_DIR)/lib/