summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-28 16:38:48 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-28 16:38:48 +0000
commit330117faf8d0c5370777b8493ba18e4c52dab33e (patch)
treef4d3b511487dea6b2494934a22e6d06ce5c98aac /toolchain
parent1a2c8d12a108e6aaee3a4b02bbe5509c554be16f (diff)
downloadbuildroot-novena-330117faf8d0c5370777b8493ba18e4c52dab33e.tar.gz
buildroot-novena-330117faf8d0c5370777b8493ba18e4c52dab33e.zip
- fix prereq of current binutils wrt gmp
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/binutils/binutils.mk12
1 files changed, 9 insertions, 3 deletions
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index eb46d7bbb..e75e4c9db 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -14,27 +14,33 @@ BINUTILS_SITE:=ftp://ftp.gnu.org/gnu/binutils/
endif
ifeq ($(BINUTILS_VERSION),2.16)
BINUTILS_SITE:=ftp://ftp.gnu.org/gnu/binutils/
+BINUTILS_NO_MPFR:=y
endif
ifeq ($(BINUTILS_VERSION),2.16.1)
BINUTILS_SITE:=ftp://ftp.gnu.org/gnu/binutils/
+BINUTILS_NO_MPFR:=y
endif
ifeq ($(BINUTILS_VERSION),2.15)
BINUTILS_SITE:=ftp://ftp.gnu.org/gnu/binutils/
+BINUTILS_NO_MPFR:=y
endif
ifeq ($(BINUTILS_VERSION),2.14)
BINUTILS_SITE:=ftp://ftp.gnu.org/gnu/binutils/
+BINUTILS_NO_MPFR:=y
endif
ifeq ($(BINUTILS_VERSION),2.13)
BINUTILS_SITE:=ftp://ftp.gnu.org/gnu/binutils/
+BINUTILS_NO_MPFR:=y
endif
ifeq ($(BINUTILS_VERSION),2.15.97)
BINUTILS_SITE:=ftp://sources.redhat.com/pub/binutils/snapshots/
+BINUTILS_NO_MPFR:=y
endif
# We do not rely on the host's gmp/mpfr but use a known working one
-BINUTILS_HOST_PREREQ:= #nothing
-BINUTILS_TARGET_PREREQ:= #nothing
-ifeq ($(BR2_BINUTILS_VERSION_2_17_50_0_9),y)
+BINUTILS_HOST_PREREQ:=
+BINUTILS_TARGET_PREREQ:=
+ifndef BINUTILS_NO_MPFR
BINUTILS_HOST_PREREQ:=$(TOOL_BUILD_DIR)/gmp/lib/libgmp.so \
$(TOOL_BUILD_DIR)/mpfr/lib/libmpfr.so