summaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /toolchain/gdb
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
downloadbuildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile.in14
-rw-r--r--toolchain/gdb/gdb.mk19
2 files changed, 19 insertions, 14 deletions
diff --git a/toolchain/gdb/Makefile.in b/toolchain/gdb/Makefile.in
deleted file mode 100644
index 50828d86f..000000000
--- a/toolchain/gdb/Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-GDB_VERSION:=$(strip $(subst ",, $(BR2_GDB_VERSION)))
-#"
-
-ifeq ($(strip $(BR2_PACKAGE_GDB)),y)
-TARGETS+=gdb_target
-endif
-
-ifeq ($(strip $(BR2_PACKAGE_GDB_SERVER)),y)
-TARGETS+=gdbserver
-endif
-
-ifeq ($(strip $(BR2_PACKAGE_GDB_CLIENT)),y)
-TARGETS+=gdbclient
-endif
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 7c3c8deaa..e8212e93f 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -187,3 +187,22 @@ gdbclient-dirclean:
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+GDB_VERSION:=$(strip $(subst ",, $(BR2_GDB_VERSION)))
+#"
+
+ifeq ($(strip $(BR2_PACKAGE_GDB)),y)
+TARGETS+=gdb_target
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_GDB_SERVER)),y)
+TARGETS+=gdbserver
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_GDB_CLIENT)),y)
+TARGETS+=gdbclient
+endif