summaryrefslogtreecommitdiffstats
path: root/toolchain/gdb/gdb.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-12-15 00:19:17 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-12-15 00:19:17 +0100
commit29a9d99b18ff793cf70ce8ebb8d0008f980f728b (patch)
tree43af7e894ca23976004336606bcae9b14272c15e /toolchain/gdb/gdb.mk
parenta2fd9751155657999b75367dea5b081dad1254b3 (diff)
parentc375022823a1c36a03fe576924ef4fcf9a58499a (diff)
downloadbuildroot-novena-29a9d99b18ff793cf70ce8ebb8d0008f980f728b.tar.gz
buildroot-novena-29a9d99b18ff793cf70ce8ebb8d0008f980f728b.zip
Merge branch 'remove-external-toolchain' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'toolchain/gdb/gdb.mk')
-rw-r--r--toolchain/gdb/gdb.mk13
1 files changed, 9 insertions, 4 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 4c72a21c8..bdefd099a 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -11,11 +11,14 @@ GDB_SOURCE:=gdb-$(GDB_OFFICIAL_VERSION).tar.bz2
GDB_CAT:=$(BZCAT)
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_SOURCE),y)
-GDB_SITE:=$(VENDOR_SITE)
-GDB_PATCH_DIR:=toolchain/gdb/ext_source/$(VENDOR_PATCH_DIR)/$(GDB_OFFICIAL_VERSION)
+ GDB_SITE:=$(VENDOR_SITE)
+ GDB_PATCH_DIR:=toolchain/gdb/ext_source/$(VENDOR_PATCH_DIR)/$(GDB_OFFICIAL_VERSION)
+else ifeq ($(findstring avr32,$(GDB_VERSION)),avr32)
+ GDB_SITE:=ftp://www.at91.com/pub/buildroot/
+ GDB_PATCH_DIR:=toolchain/gdb/$(GDB_OFFICIAL_VERSION)
else
-GDB_SITE:=$(BR2_GNU_MIRROR)/gdb
-GDB_PATCH_DIR:=toolchain/gdb/$(GDB_OFFICIAL_VERSION)
+ GDB_SITE:=$(BR2_GNU_MIRROR)/gdb
+ GDB_PATCH_DIR:=toolchain/gdb/$(GDB_OFFICIAL_VERSION)
endif
ifneq ($(filter xtensa%,$(ARCH)),)
@@ -37,7 +40,9 @@ ifeq ($(GDB_VERSION),snapshot)
tar jtf $(DL_DIR)/$(GDB_SOURCE) | head -1 | cut -d"/" -f1)
ln -sf $(TOOLCHAIN_DIR)/$(shell tar jtf $(DL_DIR)/$(GDB_SOURCE) | head -1 | cut -d"/" -f1) $(GDB_DIR)
endif
+ifneq ($(wildcard $(GDB_PATCH_DIR)),)
toolchain/patch-kernel.sh $(GDB_DIR) $(GDB_PATCH_DIR) \*.patch $(GDB_PATCH_EXTRA)
+endif
$(CONFIG_UPDATE) $(@D)
touch $@