summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/4.2.0/602-sdk-libstdc++-includes.patch
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2005-12-06 22:12:15 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2005-12-06 22:12:15 +0000
commit92834c567469ecb5e10aae60de0984960db60b01 (patch)
tree24666157e28d03a01d5d03f359931351dce6d0b5 /toolchain/gcc/4.2.0/602-sdk-libstdc++-includes.patch
parentb2dcdf3218434233499765b25e215a933f9dbf1c (diff)
downloadbuildroot-novena-92834c567469ecb5e10aae60de0984960db60b01.tar.gz
buildroot-novena-92834c567469ecb5e10aae60de0984960db60b01.zip
- import gcc-4.2.0
libmudflap is disabled for now. copied from 4.1.0 with slight adjustments
Diffstat (limited to 'toolchain/gcc/4.2.0/602-sdk-libstdc++-includes.patch')
-rw-r--r--toolchain/gcc/4.2.0/602-sdk-libstdc++-includes.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/toolchain/gcc/4.2.0/602-sdk-libstdc++-includes.patch b/toolchain/gcc/4.2.0/602-sdk-libstdc++-includes.patch
new file mode 100644
index 000000000..23fce7544
--- /dev/null
+++ b/toolchain/gcc/4.2.0/602-sdk-libstdc++-includes.patch
@@ -0,0 +1,20 @@
+--- gcc-4.1.0/libstdc++-v3/fragment.am 2005-03-21 11:40:14.000000000 -0600
++++ gcc-4.1.0-patched/libstdc++-v3/fragment.am 2005-04-25 20:14:39.856251785 -0500
+@@ -21,5 +21,5 @@
+ $(WARN_FLAGS) $(WERROR) -fdiagnostics-show-location=once
+
+ # -I/-D flags to pass when compiling.
+-AM_CPPFLAGS = $(GLIBCXX_INCLUDES)
++AM_CPPFLAGS = $(GLIBCXX_INCLUDES) -I$(toplevel_srcdir)/include
+
+--- gcc-4.1.0/libstdc++-v3/libmath/Makefile.am 2005-03-21 11:40:18.000000000 -0600
++++ gcc-4.1.0-patched/libstdc++-v3/libmath/Makefile.am 2005-04-25 20:14:39.682280735 -0500
+@@ -35,7 +35,7 @@
+
+ libmath_la_SOURCES = stubs.c
+
+-AM_CPPFLAGS = $(CANADIAN_INCLUDES)
++AM_CPPFLAGS = $(CANADIAN_INCLUDES) -I$(toplevel_srcdir)/include
+
+ # Only compiling "C" sources in this directory.
+ LIBTOOL = @LIBTOOL@ --tag CC