summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/4.0.4/602-sdk-libstdc++-includes.patch
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-09 13:31:55 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-09 13:31:55 +0000
commit7779fd745393c02e51976c1d1888db16adc225f8 (patch)
tree40e8e24c25635c89c73f0781c4e22bf272d55a24 /toolchain/gcc/4.0.4/602-sdk-libstdc++-includes.patch
parent19818694fe6fa3412a6636a3ed783e0d6832d6e6 (diff)
downloadbuildroot-novena-7779fd745393c02e51976c1d1888db16adc225f8.tar.gz
buildroot-novena-7779fd745393c02e51976c1d1888db16adc225f8.zip
- add gcc-4.0.4
- add knob to enable unsupported, deprecated, obsoleted versions of packages
Diffstat (limited to 'toolchain/gcc/4.0.4/602-sdk-libstdc++-includes.patch')
-rw-r--r--toolchain/gcc/4.0.4/602-sdk-libstdc++-includes.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/toolchain/gcc/4.0.4/602-sdk-libstdc++-includes.patch b/toolchain/gcc/4.0.4/602-sdk-libstdc++-includes.patch
new file mode 100644
index 000000000..c7676ae6a
--- /dev/null
+++ b/toolchain/gcc/4.0.4/602-sdk-libstdc++-includes.patch
@@ -0,0 +1,22 @@
+diff -urN gcc-4.0.0-100/libstdc++-v3/fragment.am gcc-4.0.0/libstdc++-v3/fragment.am
+--- gcc-4.0.0-100/libstdc++-v3/fragment.am 2004-10-25 15:32:40.000000000 -0500
++++ gcc-4.0.0/libstdc++-v3/fragment.am 2005-04-28 21:48:43.000000000 -0500
+@@ -18,5 +18,5 @@
+ $(WARN_FLAGS) $(WERROR) -fdiagnostics-show-location=once
+
+ # -I/-D flags to pass when compiling.
+-AM_CPPFLAGS = $(GLIBCXX_INCLUDES)
++AM_CPPFLAGS = $(GLIBCXX_INCLUDES) -I$(toplevel_srcdir)/include
+
+diff -urN gcc-4.0.0-100/libstdc++-v3/libmath/Makefile.am gcc-4.0.0/libstdc++-v3/libmath/Makefile.am
+--- gcc-4.0.0-100/libstdc++-v3/libmath/Makefile.am 2003-08-27 16:29:42.000000000 -0500
++++ gcc-4.0.0/libstdc++-v3/libmath/Makefile.am 2005-04-28 21:48:43.000000000 -0500
+@@ -32,7 +32,7 @@
+
+ libmath_la_SOURCES = stubs.c
+
+-AM_CPPFLAGS = $(CANADIAN_INCLUDES)
++AM_CPPFLAGS = $(CANADIAN_INCLUDES) -I$(toplevel_srcdir)/include
+
+ # Only compiling "C" sources in this directory.
+ LIBTOOL = @LIBTOOL@ --tag CC