summaryrefslogtreecommitdiffstats
path: root/toolchain/ccache/ccache.mk
diff options
context:
space:
mode:
authorWade Berrier <wberrier@gmail.com>2008-10-06 19:14:41 +0000
committerWade Berrier <wberrier@gmail.com>2008-10-06 19:14:41 +0000
commitaf9710538ec1ece4819415341d303fb55c837331 (patch)
tree93332a1df03e6187a0f735108235e9f1f5f1b72a /toolchain/ccache/ccache.mk
parent6f6893c633ef6d31c467a4154088b2962c93fd77 (diff)
downloadbuildroot-novena-af9710538ec1ece4819415341d303fb55c837331.tar.gz
buildroot-novena-af9710538ec1ece4819415341d303fb55c837331.zip
ccache:
-Allow user to specify custom ccache location. This allows you to build a toolchain and put it on an nfs share so other people can use the toolchain without errors about the ccache dir missing.
Diffstat (limited to 'toolchain/ccache/ccache.mk')
-rw-r--r--toolchain/ccache/ccache.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/toolchain/ccache/ccache.mk b/toolchain/ccache/ccache.mk
index 945f84056..c405e88ac 100644
--- a/toolchain/ccache/ccache.mk
+++ b/toolchain/ccache/ccache.mk
@@ -24,8 +24,9 @@ $(CCACHE_DIR1)/.patched: $(CCACHE_DIR1)/.unpacked
# Should probably patch things to use a relative path.
$(SED) "s,getenv(\"CCACHE_PATH\"),\"$(STAGING_DIR)/usr/bin-ccache\",g" \
$(CCACHE_DIR1)/execute.c
- # WARNING - this will break if the toolchain build dir is deleted.
- $(SED) "s,getenv(\"CCACHE_DIR\"),\"$(CCACHE_DIR1)/cache\",g" \
+ # WARNING - this will break if the toolchain build dir is deleted
+ # when using the default cache dir location.
+ $(SED) "s,getenv(\"CCACHE_DIR\"),\"$(BR2_CCACHE_DIR)\",g" \
$(CCACHE_DIR1)/ccache.c
mkdir -p $(CCACHE_DIR1)/cache
touch $@