summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/2.16.93/300-001_ld_makefile_patch.patch
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-17 03:38:40 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-17 03:38:40 +0000
commitf84a70f1568d3e0b02e0f200df6367e0d073fb65 (patch)
tree02583423b7fff57917797204957554aa078333a2 /toolchain/binutils/2.16.93/300-001_ld_makefile_patch.patch
parentce87884f394e4abeb271dd85c85f2d9ce66f5521 (diff)
downloadbuildroot-novena-f84a70f1568d3e0b02e0f200df6367e0d073fb65.tar.gz
buildroot-novena-f84a70f1568d3e0b02e0f200df6367e0d073fb65.zip
punt prereleases (2.15.97->2.16, 2.16.9[34]->2.17)
Diffstat (limited to 'toolchain/binutils/2.16.93/300-001_ld_makefile_patch.patch')
-rw-r--r--toolchain/binutils/2.16.93/300-001_ld_makefile_patch.patch50
1 files changed, 0 insertions, 50 deletions
diff --git a/toolchain/binutils/2.16.93/300-001_ld_makefile_patch.patch b/toolchain/binutils/2.16.93/300-001_ld_makefile_patch.patch
deleted file mode 100644
index 04a7e61e2..000000000
--- a/toolchain/binutils/2.16.93/300-001_ld_makefile_patch.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/sh -e
-## 001_ld_makefile_patch.dpatch
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Description: correct where ld scripts are installed
-## DP: Author: Chris Chimelis <chris@debian.org>
-## DP: Upstream status: N/A
-## DP: Date: ??
-
-if [ $# -ne 1 ]; then
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-fi
-
-[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
-patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
-
-case "$1" in
- -patch) patch $patch_opts -p1 < $0;;
- -unpatch) patch $patch_opts -p1 -R < $0;;
- *)
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1;;
-esac
-
-exit 0
-
-@DPATCH@
---- binutils-2.16.91.0.1/ld/Makefile.am
-+++ binutils-2.16.91.0.1/ld/Makefile.am
-@@ -20,7 +20,7 @@
- # We put the scripts in the directory $(scriptdir)/ldscripts.
- # We can't put the scripts in $(datadir) because the SEARCH_DIR
- # directives need to be different for native and cross linkers.
--scriptdir = $(tooldir)/lib
-+scriptdir = $(libdir)
-
- EMUL = @EMUL@
- EMULATION_OFILES = @EMULATION_OFILES@
---- binutils-2.16.91.0.1/ld/Makefile.in
-+++ binutils-2.16.91.0.1/ld/Makefile.in
-@@ -268,7 +268,7 @@
- # We put the scripts in the directory $(scriptdir)/ldscripts.
- # We can't put the scripts in $(datadir) because the SEARCH_DIR
- # directives need to be different for native and cross linkers.
--scriptdir = $(tooldir)/lib
-+scriptdir = $(libdir)
- BASEDIR = $(srcdir)/..
- BFDDIR = $(BASEDIR)/bfd
- INCDIR = $(BASEDIR)/include