summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /target
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
downloadbuildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'target')
-rw-r--r--target/cramfs/Makefile.in3
-rw-r--r--target/cramfs/cramfs.mk8
-rw-r--r--target/ext2/Makefile.in3
-rw-r--r--target/ext2/ext2root.mk8
-rw-r--r--target/jffs2/Makefile.in3
-rw-r--r--target/jffs2/jffs2root.mk10
-rw-r--r--target/squashfs/Makefile.in3
-rw-r--r--target/squashfs/squashfsroot.mk8
-rw-r--r--target/tar/Makefile.in3
-rw-r--r--target/tar/tarroot.mk9
10 files changed, 41 insertions, 17 deletions
diff --git a/target/cramfs/Makefile.in b/target/cramfs/Makefile.in
deleted file mode 100644
index 45d9b67ce..000000000
--- a/target/cramfs/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_TARGET_ROOTFS_CRAMFS)),y)
-TARGETS+=cramfsroot
-endif
diff --git a/target/cramfs/cramfs.mk b/target/cramfs/cramfs.mk
index a00af6c17..e4766cfad 100644
--- a/target/cramfs/cramfs.mk
+++ b/target/cramfs/cramfs.mk
@@ -49,3 +49,11 @@ cramfsroot-clean:
cramfsroot-dirclean:
rm -rf $(CRAMFS_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_TARGET_ROOTFS_CRAMFS)),y)
+TARGETS+=cramfsroot
+endif
diff --git a/target/ext2/Makefile.in b/target/ext2/Makefile.in
deleted file mode 100644
index 990407718..000000000
--- a/target/ext2/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_TARGET_ROOTFS_EXT2)),y)
-TARGETS+=ext2root
-endif
diff --git a/target/ext2/ext2root.mk b/target/ext2/ext2root.mk
index 8dfa513e1..2d80999fe 100644
--- a/target/ext2/ext2root.mk
+++ b/target/ext2/ext2root.mk
@@ -111,3 +111,11 @@ ext2root-clean:
ext2root-dirclean:
rm -rf $(GENEXT2_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_TARGET_ROOTFS_EXT2)),y)
+TARGETS+=ext2root
+endif
diff --git a/target/jffs2/Makefile.in b/target/jffs2/Makefile.in
deleted file mode 100644
index 31452eba8..000000000
--- a/target/jffs2/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
-TARGETS+=jffs2root
-endif
diff --git a/target/jffs2/jffs2root.mk b/target/jffs2/jffs2root.mk
index 3e64a62d5..0dad3f416 100644
--- a/target/jffs2/jffs2root.mk
+++ b/target/jffs2/jffs2root.mk
@@ -64,5 +64,11 @@ jffs2root-clean: mtd-host-clean
jffs2root-dirclean: mtd-host-dirclean
-rm -f $(JFFS2_TARGET)
-
-
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
+TARGETS+=jffs2root
+endif
diff --git a/target/squashfs/Makefile.in b/target/squashfs/Makefile.in
deleted file mode 100644
index 2278d720c..000000000
--- a/target/squashfs/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS)),y)
-TARGETS+=squashfsroot
-endif
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index e120172ba..5a4536fed 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -49,3 +49,11 @@ squashfsroot-clean:
squashfsroot-dirclean:
rm -rf $(SQUASHFS_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS)),y)
+TARGETS+=squashfsroot
+endif
diff --git a/target/tar/Makefile.in b/target/tar/Makefile.in
deleted file mode 100644
index d5f130899..000000000
--- a/target/tar/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_TARGET_ROOTFS_TAR)),y)
-TARGETS+=tarroot
-endif
diff --git a/target/tar/tarroot.mk b/target/tar/tarroot.mk
index a7627bf40..e85030b97 100644
--- a/target/tar/tarroot.mk
+++ b/target/tar/tarroot.mk
@@ -23,3 +23,12 @@ tarroot-source:
tarroot-clean:
tarroot-dirclean:
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_TARGET_ROOTFS_TAR)),y)
+TARGETS+=tarroot
+endif