summaryrefslogtreecommitdiffstats
path: root/target/u-boot
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-19 22:42:03 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-19 22:42:03 +0000
commit5a4676144660f6e92bbe5e0de6b38094df155021 (patch)
tree064a71e50fa34e6a26c44b5597b3c4e1fc45556a /target/u-boot
parentb71c76a10a21320a9401cc4246079e9f4f47fae1 (diff)
downloadbuildroot-novena-5a4676144660f6e92bbe5e0de6b38094df155021.tar.gz
buildroot-novena-5a4676144660f6e92bbe5e0de6b38094df155021.zip
Bump u-boot to -2009.01-rc3, and add possibility to apply the arch-at91 patches if using an at91
Diffstat (limited to 'target/u-boot')
-rw-r--r--target/u-boot/Config.in16
-rw-r--r--target/u-boot/Makefile.in3
2 files changed, 12 insertions, 7 deletions
diff --git a/target/u-boot/Config.in b/target/u-boot/Config.in
index 981b1787b..55c20be03 100644
--- a/target/u-boot/Config.in
+++ b/target/u-boot/Config.in
@@ -17,8 +17,11 @@ choice
help
Select the specific U-Boot version you want to use
-config BR2_TARGET_UBOOT_2009_01_RC1
- bool "u-boot-2009.01-rc1"
+#config BR2_TARGET_UBOOT_2009_01
+# bool "u-boot-2009.01"
+
+config BR2_TARGET_UBOOT_2009_01_RC3
+ bool "u-boot-2009.01-rc3"
config BR2_TARGET_UBOOT_2008_10
bool "u-boot-2008.10"
@@ -31,24 +34,23 @@ config BR2_TARGET_UBOOT_1_2_0_ATMEL
bool "u-boot-1.2.0-atmel"
depends on BR2_TARGET_AT91
-#config BR2_TARGET_UBOOT_2009_01
-# bool "u-boot-2009.01"
-
endchoice
config BR2_UBOOT_VERSION
string
- default "2009.01-rc1" if BR2_TARGET_UBOOT_2009_01_RC1
+ default "2009.01" if BR2_TARGET_UBOOT_2009_01
+ default "2009.01-rc3" if BR2_TARGET_UBOOT_2009_01_RC3
default "2008.10" if BR2_TARGET_UBOOT_2008_10
default "1.3.4" if BR2_TARGET_UBOOT_1_3_4
default "1.2.0-atmel" if BR2_TARGET_UBOOT_1_2_0_ATMEL
- default "2009.01" if BR2_TARGET_UBOOT_2009_01
config BR2_U_BOOT_SITE
string
default "$(BR2_ATMEL_MIRROR)" if BR2_TARGET_UBOOT_1_2_0_ATMEL
default "ftp://ftp.denx.de/pub/u-boot"
+source "target/device/Config.in.u-boot"
+
config BR2_TARGET_UBOOT_CUSTOM_PATCH
string "custom patch"
help
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index baf331da7..1386e03a7 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -88,6 +88,9 @@ $(U_BOOT_DIR)/.patched: $(U_BOOT_DIR)/.unpacked
toolchain/patch-kernel.sh $(U_BOOT_DIR) target/u-boot/$(U_BOOT_VERSION) \
u-boot-$(U_BOOT_VERSION)-\*.patch \
u-boot-$(U_BOOT_VERSION)-\*.patch.$(ARCH)
+ifneq ($(strip $(U_BOOT_ARCH_PATCH_DIR)),"")
+ toolchain/patch-kernel.sh $(U_BOOT_DIR) $(U_BOOT_ARCH_PATCH_DIR) \*.patch
+endif
ifneq ($(strip $(BR2_TARGET_UBOOT_CUSTOM_PATCH)),"")
@mkdir -p $(U_BOOT_PATCH_DIR)
cp -dpr $(BR2_TARGET_UBOOT_CUSTOM_PATCH) $(U_BOOT_PATCH_DIR)