summaryrefslogtreecommitdiffstats
path: root/target/tar
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /target/tar
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
downloadbuildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'target/tar')
-rw-r--r--target/tar/Makefile.in3
-rw-r--r--target/tar/tarroot.mk9
2 files changed, 9 insertions, 3 deletions
diff --git a/target/tar/Makefile.in b/target/tar/Makefile.in
deleted file mode 100644
index d5f130899..000000000
--- a/target/tar/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_TARGET_ROOTFS_TAR)),y)
-TARGETS+=tarroot
-endif
diff --git a/target/tar/tarroot.mk b/target/tar/tarroot.mk
index a7627bf40..e85030b97 100644
--- a/target/tar/tarroot.mk
+++ b/target/tar/tarroot.mk
@@ -23,3 +23,12 @@ tarroot-source:
tarroot-clean:
tarroot-dirclean:
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_TARGET_ROOTFS_TAR)),y)
+TARGETS+=tarroot
+endif