summaryrefslogtreecommitdiffstats
path: root/target/squashfs/squashfsroot.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-26 08:36:38 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-26 08:52:22 +0100
commitbe8a104c3cd65190e32aebcbc8430fb23c42361f (patch)
tree1e6f400f87f7005c7a3cf381669dd36c174d30de /target/squashfs/squashfsroot.mk
parentc4ba3fdae5a576ed26815a3ef637614b2017fc18 (diff)
downloadbuildroot-novena-be8a104c3cd65190e32aebcbc8430fb23c42361f.tar.gz
buildroot-novena-be8a104c3cd65190e32aebcbc8430fb23c42361f.zip
squashfs: pass CFLAGS/LDFLAGS and add host-zlib dependency
Squashfs depends on host-zlib, so we add this as a dependency. As host-zlib is installed in $(HOST_DIR), we must pass $(HOST_CFLAGS) and $(HOST_LDFLAGS). Unfortunately, if we pass CFLAGS=$(HOST_CFLAGS), we override the CFLAGS defined in the Makefile, and the build fails. Therefore, we borrow a patch from OpenEmbedded to fix this problem. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'target/squashfs/squashfsroot.mk')
-rw-r--r--target/squashfs/squashfsroot.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index ebb0cd2bd..63adc5c36 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -18,9 +18,9 @@ $(SQUASHFS_DIR)/.unpacked: $(DL_DIR)/$(SQUASHFS_SOURCE) #$(SQUASHFS_PATCH)
touch $@
$(SQUASHFS_DIR)/squashfs-tools/mksquashfs: $(SQUASHFS_DIR)/.unpacked
- $(MAKE) -C $(SQUASHFS_DIR)/squashfs-tools
+ $(MAKE) CFLAGS="$(HOST_CFLAGS)" LDFLAGS="$(HOST_LDFLAGS)" -C $(SQUASHFS_DIR)/squashfs-tools
-squashfs: $(SQUASHFS_DIR)/squashfs-tools/mksquashfs
+squashfs: host-zlib $(SQUASHFS_DIR)/squashfs-tools/mksquashfs
squashfs-source: $(DL_DIR)/$(SQUASHFS_SOURCE)