summaryrefslogtreecommitdiffstats
path: root/target/linux/Makefile.in
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-18 18:07:19 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-18 18:07:19 +0000
commit62b5ae4b66f214fb2f105590bdac14133f0cdc20 (patch)
treee5371fb6c1bc8f7d9736ed05a2af892731bfdf92 /target/linux/Makefile.in
parent88494a7bbebf55051368175c146dc9ff1e6a34fd (diff)
downloadbuildroot-novena-62b5ae4b66f214fb2f105590bdac14133f0cdc20.tar.gz
buildroot-novena-62b5ae4b66f214fb2f105590bdac14133f0cdc20.zip
Fix INITRAMFS target that was broken. Get rid of config stuff out of the top-level directory. Finally fix Linux kernel module building such that modules are built and installed first followed by rest of packages. This allows for packages to build external Linux kernel modules.
Diffstat (limited to 'target/linux/Makefile.in')
-rw-r--r--target/linux/Makefile.in15
1 files changed, 8 insertions, 7 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index bbb3726d6..db7be0e69 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -131,12 +131,7 @@ $(LINUX26_KERNEL): $(LINUX26_DIR)/.depend_done
cp -dpf $(LINUX26_DIR)/$(LINUX26_BINLOC) $(LINUX26_KERNEL)
touch -c $@
-$(TARGET_DIR)/boot/$(LINUX26_FORMAT): $(LINUX26_KERNEL)
- [ -d $(TARGET_DIR)/boot/ ] || mkdir $(TARGET_DIR)/boot
- cp -dpf $(LINUX26_DIR)/$(LINUX26_BINLOC) $(LINUX26_DIR)/System.map $(TARGET_DIR)/boot/
- touch -c $@
-
-linux26-modules $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep: $(LINUX26_DIR)/.depend_done
+$(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep: $(LINUX26_DIR)/.configured
rm -rf $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)
rm -f $(TARGET_DIR)/sbin/cardmgr
$(MAKE) $(LINUX26_MAKE_FLAGS) -C $(LINUX26_DIR) modules
@@ -145,6 +140,7 @@ linux26-modules $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep: $(LINU
INSTALL_MOD_PATH=$(TARGET_DIR) modules_install
rm -f $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/build
rm -f $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/source
+ $(STAGING_DIR)/bin/$(GNU_TARGET_NAME)-depmod26 -b $(TARGET_DIR) $(LINUX_HEADERS_VERSION)
touch -c $@
linux26-menuconfig: $(LINUX26_DIR)/.patched host-sed
@@ -152,7 +148,12 @@ linux26-menuconfig: $(LINUX26_DIR)/.patched host-sed
$(MAKE) $(LINUX26_MAKE_FLAGS) -C $(LINUX26_DIR) menuconfig
-[ -f $(LINUX26_DIR)/.config ] && touch $(LINUX26_DIR)/.configured
-linux26: cross-depmod26 $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep $(INITRAMFS_TARGET) $(TARGET_DIR)/boot/$(LINUX26_FORMAT)
+linux26: $(INITRAMFS_TARGET) $(LINUX26_KERNEL)
+
+$(LINUX26_DIR)/.modules_installed: $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep
+ touch $@
+
+linux26-modules: cross-depmod26 $(LINUX26_DIR)/.modules_installed
linux26-source: $(DL_DIR)/$(LINUX26_SOURCE)