summaryrefslogtreecommitdiffstats
path: root/target/jffs2/jffs2root.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /target/jffs2/jffs2root.mk
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
downloadbuildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'target/jffs2/jffs2root.mk')
-rw-r--r--target/jffs2/jffs2root.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/target/jffs2/jffs2root.mk b/target/jffs2/jffs2root.mk
index 3e64a62d5..0dad3f416 100644
--- a/target/jffs2/jffs2root.mk
+++ b/target/jffs2/jffs2root.mk
@@ -64,5 +64,11 @@ jffs2root-clean: mtd-host-clean
jffs2root-dirclean: mtd-host-dirclean
-rm -f $(JFFS2_TARGET)
-
-
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
+TARGETS+=jffs2root
+endif