summaryrefslogtreecommitdiffstats
path: root/target/device
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-29 21:22:23 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-29 21:22:23 +0000
commit98175bd43dbfc70f473cca6759bc8a2f4e655734 (patch)
tree4fb0f5cefa3728fa2b7d895003f321e164db96a0 /target/device
parent37a085768535229cb0025822df2b0b23c9804edb (diff)
downloadbuildroot-novena-98175bd43dbfc70f473cca6759bc8a2f4e655734.tar.gz
buildroot-novena-98175bd43dbfc70f473cca6759bc8a2f4e655734.zip
- revert part of 20119 (renaming BR2_ARM_.ABI to BR2_.ABI)
Diffstat (limited to 'target/device')
-rw-r--r--target/device/Arm/Config.in8
-rw-r--r--target/device/Arm/Makefile.in2
-rw-r--r--target/device/Arm/integrator926_defconfig4
-rw-r--r--target/device/Arm/integrator926_huge_defconfig4
-rw-r--r--target/device/Atmel/at91rm9200df/at91rm9200df_defconfig4
-rw-r--r--target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig4
-rw-r--r--target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig4
-rw-r--r--target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig4
8 files changed, 16 insertions, 18 deletions
diff --git a/target/device/Arm/Config.in b/target/device/Arm/Config.in
index de50fea77..36934ee09 100644
--- a/target/device/Arm/Config.in
+++ b/target/device/Arm/Config.in
@@ -3,16 +3,15 @@ menuconfig BR2_TARGET_ARM
depends BR2_arm
default n
-if BR2_TARGET_ARM
comment "Arm based Device Support"
- depends BR2_arm
+ depends BR2_arm && BR2_TARGET_ARM
config BR2_TARGET_ARM_INTEGRATOR_926
bool "Integrator arm926"
- depends BR2_arm
+ depends BR2_arm && BR2_TARGET_ARM
default n
select BR2_PACKAGE_LINUX
- select BR2_EABI
+ select BR2_ARM_EABI
select BR2_KERNEL_HEADERS_2_6_22
select BR2_PTHREADS
select BR2_arm926t
@@ -20,4 +19,3 @@ config BR2_TARGET_ARM_INTEGRATOR_926
An ARM integrator 926 board for use with qemu.
This one has an MMU.
-endif
diff --git a/target/device/Arm/Makefile.in b/target/device/Arm/Makefile.in
index db1b81240..a55389e7f 100644
--- a/target/device/Arm/Makefile.in
+++ b/target/device/Arm/Makefile.in
@@ -7,7 +7,7 @@ UCLIBC_CONFIG_FILE:=target/device/Arm/uClibc.integrator926.config
endif
# pin some settings
-BR2_EABI:=y
+BR2_ARM_EABI:=y
BR2_GNU_TARGET_SUFFIX:="linux-uclibcgnueabi"
BR2_DEFAULT_KERNEL_HEADERS:="2.6.22.8"
endif
diff --git a/target/device/Arm/integrator926_defconfig b/target/device/Arm/integrator926_defconfig
index 2b4d9c676..1977375eb 100644
--- a/target/device/Arm/integrator926_defconfig
+++ b/target/device/Arm/integrator926_defconfig
@@ -39,8 +39,8 @@ BR2_arm926t=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="ARM926T"
-# BR2_OABI is not set
-BR2_EABI=y
+# BR2_ARM_OABI is not set
+BR2_ARM_EABI=y
# BR2_x86_i386 is not set
# BR2_x86_i486 is not set
# BR2_x86_i586 is not set
diff --git a/target/device/Arm/integrator926_huge_defconfig b/target/device/Arm/integrator926_huge_defconfig
index 72c0d0757..43e436ca3 100644
--- a/target/device/Arm/integrator926_huge_defconfig
+++ b/target/device/Arm/integrator926_huge_defconfig
@@ -39,8 +39,8 @@ BR2_arm926t=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="ARM926T"
-# BR2_OABI is not set
-BR2_EABI=y
+# BR2_ARM_OABI is not set
+BR2_ARM_EABI=y
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
BR2_GCC_TARGET_TUNE="arm9tdmi"
diff --git a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig b/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
index ddbf9b624..38cdc8fcd 100644
--- a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
+++ b/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
@@ -153,8 +153,8 @@ BR2_GCC_VERSION_4_2_1=y
BR2_GCC_SUPPORTS_SYSROOT=y
# BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE is not set
BR2_GCC_VERSION="4.2.1"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
BR2_TOOLCHAIN_SYSROOT=y
# BR2_GCC_USE_SJLJ_EXCEPTIONS is not set
BR2_EXTRA_GCC_CONFIG_OPTIONS=""
diff --git a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig b/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
index e11611d25..69afb804b 100644
--- a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
+++ b/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
@@ -42,8 +42,8 @@ BR2_generic_arm=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="GENERIC_ARM"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
diff --git a/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig b/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
index 54af41f40..36dd77a5b 100644
--- a/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
+++ b/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
@@ -44,8 +44,8 @@ BR2_generic_arm=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="GENERIC_ARM"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
diff --git a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig b/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
index 265eb0b91..5558c2cf3 100644
--- a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
+++ b/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
@@ -44,8 +44,8 @@ BR2_generic_arm=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="GENERIC_ARM"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"