summaryrefslogtreecommitdiffstats
path: root/target/device/xtensa/Makefile.in
diff options
context:
space:
mode:
authorMaxim Grigoriev <maxim2405@gmail.com>2009-07-24 02:17:22 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-07-24 02:17:22 +0200
commit5ddb904a8620bceddd4df1c05c7342e10592c0c3 (patch)
tree0e01403aa2e63e0f36922cd10bda0cb31f4f6952 /target/device/xtensa/Makefile.in
parentcd0b1ce3b7934c631477ad3262316199b73cce89 (diff)
downloadbuildroot-novena-5ddb904a8620bceddd4df1c05c7342e10592c0c3.tar.gz
buildroot-novena-5ddb904a8620bceddd4df1c05c7342e10592c0c3.zip
target/; xtensa support
Part of #163. Signed-off-by: Maxim Grigoriev <maxim2405@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target/device/xtensa/Makefile.in')
-rw-r--r--target/device/xtensa/Makefile.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/device/xtensa/Makefile.in b/target/device/xtensa/Makefile.in
new file mode 100644
index 000000000..f3248962f
--- /dev/null
+++ b/target/device/xtensa/Makefile.in
@@ -0,0 +1,14 @@
+ifeq ($(strip $(BR2_TARGET_XTENSA_XTAV60)),y)
+# UCLIBC_CONFIG_FILE:=target/device/xtensa/xtav60/uClibc.config
+# BR2_PACKAGE_BUSYBOX_CONFIG:=target/device/xtensa/xtav60/busybox.config
+TARGET_SKELETON_PATCH:=target/device/xtensa
+endif
+
+# Custom device table patch used when targeting ISS:
+OLD_TARGET_DEVICE_TABLE := $(TARGET_DEVICE_TABLE)
+TARGET_DEVICE_TABLE := target/device/xtensa/device_table.txt
+makedevs:
+ @echo "Applying patch to $(TARGET_DEVICE_TABLE)"
+ cp -f $(OLD_TARGET_DEVICE_TABLE) $(TARGET_DEVICE_TABLE)
+ patch -p1 -g 0 < target/device/xtensa/device_table.diff
+