summaryrefslogtreecommitdiffstats
path: root/target/device/KwikByte
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-30 17:35:13 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-09-05 14:43:17 +0200
commit79c213fbe5aa188e60563b88708e267cfe5bf4ec (patch)
tree1fbaf847e0ae431d0156fd5b4e69543b463cdbe9 /target/device/KwikByte
parent5c4555d1f54f4ede48729f78119d12b696f72d76 (diff)
downloadbuildroot-novena-79c213fbe5aa188e60563b88708e267cfe5bf4ec.tar.gz
buildroot-novena-79c213fbe5aa188e60563b88708e267cfe5bf4ec.zip
target: use qstrip
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'target/device/KwikByte')
-rw-r--r--target/device/KwikByte/Makefile.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/target/device/KwikByte/Makefile.in b/target/device/KwikByte/Makefile.in
index 347d6ab60..d889bc258 100644
--- a/target/device/KwikByte/Makefile.in
+++ b/target/device/KwikByte/Makefile.in
@@ -1,17 +1,15 @@
ifeq ($(BR2_TARGET_KWIKBYTE),y)
-BOARD_NAME:=$(strip $(subst ",, $(BR2_BOARD_NAME)))
-BOARD_PATH:=$(strip $(subst ",, $(BR2_BOARD_PATH)))
+BOARD_NAME:=$(call qstrip,$(BR2_BOARD_NAME))
+BOARD_PATH:=$(call qstrip,$(BR2_BOARD_PATH))
# These are set by Config.in
-DOWNLOAD_LINUX26_VERSION:=$(strip $(subst ",, $(BR2_DOWNLOAD_LINUX26_VERSION)))
-#"))
+DOWNLOAD_LINUX26_VERSION:=$(call qstrip,$(BR2_DOWNLOAD_LINUX26_VERSION))
ifeq ($(DOWNLOAD_LINUX26_VERSION),)
DOWNLOAD_LINUX26_VERSION=$(LINUX_HEADERS_VERSION)
endif
-LINUX26_VERSION:=$(strip $(subst ",, $(BR2_LINUX26_VERSION)))
-#"))
+LINUX26_VERSION:=$(call qstrip,$(BR2_LINUX26_VERSION))
ifeq ($(LINUX26_VERSION),)
LINUX26_VERSION=$(LINUX_HEADERS_VERSION)
endif