summaryrefslogtreecommitdiffstats
path: root/target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-008-Makefile.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-14 18:36:34 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-10 21:05:12 +0200
commit1cee7b34b479d29ad090e2fc76d58aa5cc6e93a2 (patch)
tree37eedbfe25d113c1a8d2072adebc7a1ba6a2831d /target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-008-Makefile.patch
parentdac82dbe7a98caf71e754bcc26d83b48475f677a (diff)
downloadbuildroot-novena-1cee7b34b479d29ad090e2fc76d58aa5cc6e93a2.tar.gz
buildroot-novena-1cee7b34b479d29ad090e2fc76d58aa5cc6e93a2.zip
u-boot: remove arch specific patches infrastructure
A very complicated infrastructure for just a special case, for an ancient version of U-Boot. Recent versions of U-Boot are reported to work just fine on Atmel ARM evaluation boards. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-008-Makefile.patch')
-rw-r--r--target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-008-Makefile.patch64
1 files changed, 0 insertions, 64 deletions
diff --git a/target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-008-Makefile.patch b/target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-008-Makefile.patch
deleted file mode 100644
index 176eed55d..000000000
--- a/target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-008-Makefile.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-diff -urN u-boot-2008.10-0rig//Makefile u-boot-2008.10/Makefile
---- u-boot-2008.10-0rig//Makefile 2008-12-31 18:11:18.000000000 +0100
-+++ u-boot-2008.10/Makefile 2008-12-31 18:39:58.000000000 +0100
-@@ -20,6 +20,7 @@
- # Foundation, Inc., 59 Temple Place, Suite 330, Boston,
- # MA 02111-1307 USA
- #
-+BUILD_DATE= $(shell date +%F)
-
- VERSION = 2008
- PATCHLEVEL = 10
-@@ -294,6 +295,22 @@
- ALL += $(obj)u-boot.ldr
- endif
-
-+ifneq ($(BOARDNAME),)
-+BINARY := $(BOARDNAME)-u-boot-$(U_BOOT_VERSION)-$(BUILD_DATE)
-+BINARY_BIN := $(obj)$(BINARY).bin
-+BINARY_GZ := $(obj)$(BINARY).gz
-+ALL += $(BINARY_BIN)
-+ALL += $(BINARY_GZ)
-+else
-+BINARY := u-boot
-+BINARY_BIN := $(obj)$(BINARY).bin
-+BINARY_GZ := $(obj)$(BINARY).gz
-+endif
-+
-+ifeq ($(DESTDIR),)
-+DESTDIR=binaries
-+endif
-+
- all: $(ALL)
-
- $(obj)u-boot.hex: $(obj)u-boot
-@@ -302,9 +319,20 @@
- $(obj)u-boot.srec: $(obj)u-boot
- $(OBJCOPY) -O srec $< $@
-
--$(obj)u-boot.bin: $(obj)u-boot
-+$(BINARY_BIN): $(obj)u-boot
- $(OBJCOPY) ${OBJCFLAGS} -O binary $< $@
-
-+$(BINARY_GZ): $(BINARY_BIN)
-+ gzip -c $(BINARY_BIN) > $(BINARY_GZ)
-+
-+install: all
-+ -install -d $(DESTDIR)
-+ install $(BINARY_BIN) $(DESTDIR)
-+
-+tftp: install
-+ cp $(BINARY_GZ) $(TFTPBOOT)/$(BINARY).gz
-+ cp $(BINARY_BIN) $(TFTPBOOT)/$(BINARY).bin
-+
- $(obj)u-boot.ldr: $(obj)u-boot
- $(LDR) -T $(CONFIG_BFIN_CPU) -f -c $@ $< $(LDR_FLAGS)
-
-@@ -3295,6 +3324,7 @@
- -o -name '*.srec' -o -name '*.bin' -o -name u-boot.img \) \
- -print0 \
- | xargs -0 rm -f
-+ @rm -f $(obj)u-boot-*.gz
- @rm -f $(OBJS) $(obj)*.bak $(obj)ctags $(obj)etags $(obj)TAGS \
- $(obj)cscope.* $(obj)*.*~
- @rm -f $(obj)u-boot $(obj)u-boot.map $(obj)u-boot.hex $(ALL)