summaryrefslogtreecommitdiffstats
path: root/target/device/Atmel/arch-arm/kernel-patches-2.6.21.1/linux-2.6.21.1-at91-1-update.patch
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-18 08:46:41 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-18 08:46:41 +0000
commitafec6787450ff42906cb3ea47ff94c9dc887c5b3 (patch)
treee02ac1b9dcf772b18267c163fa76baa59629615a /target/device/Atmel/arch-arm/kernel-patches-2.6.21.1/linux-2.6.21.1-at91-1-update.patch
parent134a61d9f701bf544ab95ceec067fb8aca8d6229 (diff)
downloadbuildroot-novena-afec6787450ff42906cb3ea47ff94c9dc887c5b3.tar.gz
buildroot-novena-afec6787450ff42906cb3ea47ff94c9dc887c5b3.zip
Move AVR32 kernel patches to target/device/Atmel/arch-avr32
Add linux-2.6.22.1-008-atmel-gpio_mouse-setup-for-atstk1000-board.patch Move AT91 kernel patches to target/device/Atmel/arch-arm Change name from "target/device/Atmel/Linux" to "target/device/Atmel/linux" "kernel-headers" will apply all patches in $(LINUX26_KERNEL_PATCH_DIR) if this is available. Define LINUX26_KERNEL_PATCH_DIR in target/device/Atmel/Makefile.in as above "arch-arm/kernel-patches-..." if an AT91 or as above "arch-avr32/kernel-patches-..." if an AVR32 target is selected Test build done for arm,avr32 and x86
Diffstat (limited to 'target/device/Atmel/arch-arm/kernel-patches-2.6.21.1/linux-2.6.21.1-at91-1-update.patch')
-rw-r--r--target/device/Atmel/arch-arm/kernel-patches-2.6.21.1/linux-2.6.21.1-at91-1-update.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/target/device/Atmel/arch-arm/kernel-patches-2.6.21.1/linux-2.6.21.1-at91-1-update.patch b/target/device/Atmel/arch-arm/kernel-patches-2.6.21.1/linux-2.6.21.1-at91-1-update.patch
new file mode 100644
index 000000000..7809c2463
--- /dev/null
+++ b/target/device/Atmel/arch-arm/kernel-patches-2.6.21.1/linux-2.6.21.1-at91-1-update.patch
@@ -0,0 +1,36 @@
+diff -urN linux-2.6.21.1-0rig/drivers/video/atmel_lcdfb.c linux-2.6.21.1/drivers/video/atmel_lcdfb.c
+--- linux-2.6.21.1-0rig/drivers/video/atmel_lcdfb.c 2007-05-12 13:28:34.000000000 +0200
++++ linux-2.6.21.1/drivers/video/atmel_lcdfb.c 2007-05-12 19:41:45.000000000 +0200
+@@ -540,7 +540,7 @@
+ info->fix = atmel_lcdfb_fix;
+
+ /* Enable LCDC Clocks */
+- if (cpu_is_at91sam9261() {
++ if (cpu_is_at91sam9261()) {
+ sinfo->bus_clk = clk_get(dev, "hck1");
+ if (IS_ERR(sinfo->bus_clk)) {
+ ret = PTR_ERR(sinfo->bus_clk);
+diff -urN linux-2.6.21.1-0rig/include/asm-arm/arch-at91/cpu.h linux-2.6.21.1/include/asm-arm/arch-at91/cpu.h
+--- linux-2.6.21.1-0rig/include/asm-arm/arch-at91/cpu.h 2007-05-12 13:28:34.000000000 +0200
++++ linux-2.6.21.1/include/asm-arm/arch-at91/cpu.h 2007-05-12 13:27:28.000000000 +0200
+@@ -17,7 +17,7 @@
+ #include <asm/arch/at91_dbgu.h>
+
+
+-#define ARCH_ID_AT91RM9200 0x09290780
++#define ARCH_ID_AT91RM9200 0x09290780
+ #define ARCH_ID_AT91SAM9260 0x019803a0
+ #define ARCH_ID_AT91SAM9261 0x019703a0
+ #define ARCH_ID_AT91SAM9263 0x019607a0
+@@ -76,4 +76,11 @@
+ #define cpu_is_at91sam9rl() (0)
+ #endif
+
++#define cpu_is_at32ap7000() (0)
++#define cpu_is_at32ap7001() (0)
++#define cpu_is_at32ap7002() (0)
++#define cpu_is_at32ap7200() (0)
++#define cpu_is_at32ap7010() (0)
++#define cpu_is_at32ap7020() (0)
++
+ #endif