summaryrefslogtreecommitdiffstats
path: root/target/device/Atmel/Makefile.in
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-18 08:46:41 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-18 08:46:41 +0000
commitafec6787450ff42906cb3ea47ff94c9dc887c5b3 (patch)
treee02ac1b9dcf772b18267c163fa76baa59629615a /target/device/Atmel/Makefile.in
parent134a61d9f701bf544ab95ceec067fb8aca8d6229 (diff)
downloadbuildroot-novena-afec6787450ff42906cb3ea47ff94c9dc887c5b3.tar.gz
buildroot-novena-afec6787450ff42906cb3ea47ff94c9dc887c5b3.zip
Move AVR32 kernel patches to target/device/Atmel/arch-avr32
Add linux-2.6.22.1-008-atmel-gpio_mouse-setup-for-atstk1000-board.patch Move AT91 kernel patches to target/device/Atmel/arch-arm Change name from "target/device/Atmel/Linux" to "target/device/Atmel/linux" "kernel-headers" will apply all patches in $(LINUX26_KERNEL_PATCH_DIR) if this is available. Define LINUX26_KERNEL_PATCH_DIR in target/device/Atmel/Makefile.in as above "arch-arm/kernel-patches-..." if an AT91 or as above "arch-avr32/kernel-patches-..." if an AVR32 target is selected Test build done for arm,avr32 and x86
Diffstat (limited to 'target/device/Atmel/Makefile.in')
-rw-r--r--target/device/Atmel/Makefile.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/target/device/Atmel/Makefile.in b/target/device/Atmel/Makefile.in
index ae10a20cb..e5780988f 100644
--- a/target/device/Atmel/Makefile.in
+++ b/target/device/Atmel/Makefile.in
@@ -44,7 +44,17 @@ LINUX26_BINLOC=$(LINUX26_FORMAT)
LINUX26_COPYTO:=/tftpboot
-LINUX26_PATCH_DIR:=target/device/Atmel/Linux/kernel-patches-$(DOWNLOAD_LINUX26_VERSION)
+# Patch during kernel header build
+ifeq ($(BR2_avr32),y)
+LINUX26_KERNEL_PATCH_DIR:=target/device/Atmel/arch-avr32/kernel-patches-$(DOWNLOAD_LINUX26_VERSION)
+endif
+
+# Patch during kernel build
+ifeq ($(BR2_arm),y)
+#LINUX26_PATCH_DIR:=target/device/Atmel/arch-at91/kernel-patches-$(DOWNLOAD_LINUX26_VERSION)
+LINUX26_KERNEL_PATCH_DIR:=target/device/Atmel/arch-at91/kernel-patches-$(DOWNLOAD_LINUX26_VERSION)
+endif
+
# The board specific Makefile.in can redefine BOARD_NAME's
LINUX_BOARD_NAME:=$(BOARD_NAME)
@@ -64,7 +74,7 @@ UBOOT_CONFIG:=$(UBOOT_BOARD_NAME)_config
UBOOT_CONFIG_FILE:=$(BOARD_PATH)/u-boot/$(UBOOT_BOARD_NAME).h
ifeq ($(strip $(BR2_PACKAGE_LINUX)),y)
-include $(ATMEL_PATH)/Linux/linux.mk
+include $(ATMEL_PATH)/linux/linux.mk
endif
ifeq ($(strip $(BR2_TARGET_UBOOT)),y)