summaryrefslogtreecommitdiffstats
path: root/target/cpio
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-03-20 16:52:44 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-03-20 16:52:44 +0000
commitf94a44c3ad06ae6bab203a3dda314b9ed98785e0 (patch)
treecf38157262febf2af1fac1bdd7489a7d5635396f /target/cpio
parent0e59ed02089d4c337c1ab2edcc62672ca51425f9 (diff)
downloadbuildroot-novena-f94a44c3ad06ae6bab203a3dda314b9ed98785e0.tar.gz
buildroot-novena-f94a44c3ad06ae6bab203a3dda314b9ed98785e0.zip
- use numeric values for the superuser to be more portable.
Closes #1250
Diffstat (limited to 'target/cpio')
-rw-r--r--target/cpio/cpioroot.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/cpio/cpioroot.mk b/target/cpio/cpioroot.mk
index 6cff4dde6..1a69b5002 100644
--- a/target/cpio/cpioroot.mk
+++ b/target/cpio/cpioroot.mk
@@ -19,7 +19,7 @@ cpioroot: host-fakeroot makedevs cpioroot-init
rm -f $(STAGING_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
touch $(STAGING_DIR)/.fakeroot.00000
cat $(STAGING_DIR)/.fakeroot* > $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
- echo "chown -R root:root $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
+ echo "chown -R 0:0 $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
ifneq ($(TARGET_DEVICE_TABLE),)
# Use fakeroot to pretend to create all needed device nodes
echo "$(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \