summaryrefslogtreecommitdiffstats
path: root/target/cpio
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-15 16:49:39 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-15 16:49:39 +0000
commit0091f181efdb042e778a357df0ba8ffaddfc9b0c (patch)
tree12579ad566f77af82be219c517dc9b23738058f0 /target/cpio
parent2f67d9e2fe7bbec10e67bf7e52999c594c4d6400 (diff)
downloadbuildroot-novena-0091f181efdb042e778a357df0ba8ffaddfc9b0c.tar.gz
buildroot-novena-0091f181efdb042e778a357df0ba8ffaddfc9b0c.zip
- do not use TARGET_DEVICE_TABLE if is is empty
Diffstat (limited to 'target/cpio')
-rw-r--r--target/cpio/cpioroot.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/cpio/cpioroot.mk b/target/cpio/cpioroot.mk
index 8f460c713..6cff4dde6 100644
--- a/target/cpio/cpioroot.mk
+++ b/target/cpio/cpioroot.mk
@@ -20,9 +20,11 @@ cpioroot: host-fakeroot makedevs cpioroot-init
touch $(STAGING_DIR)/.fakeroot.00000
cat $(STAGING_DIR)/.fakeroot* > $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
echo "chown -R root:root $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
+ifneq ($(TARGET_DEVICE_TABLE),)
# Use fakeroot to pretend to create all needed device nodes
echo "$(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
>> $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
+endif
# Use fakeroot so tar believes the previous fakery
echo "cd $(TARGET_DIR) && find . | cpio --quiet -o -H newc > $(CPIO_TARGET)" \
>> $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))