summaryrefslogtreecommitdiffstats
path: root/sources
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-01-24 19:43:36 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-01-24 19:43:36 +0000
commita3f9025ded08968b5072f8e0b0bb889686bd68b9 (patch)
treeff1f40683ac15e5578c54aa69a5f1f4221ab9a2d /sources
parent78fe4bffde5f0feec20e2b7f9e065b48faad80f0 (diff)
downloadbuildroot-novena-a3f9025ded08968b5072f8e0b0bb889686bd68b9.tar.gz
buildroot-novena-a3f9025ded08968b5072f8e0b0bb889686bd68b9.zip
Fix libstdc++-v3/configure.target to set the config/os dir correctly
when building inside a native uClibc environment.
Diffstat (limited to 'sources')
-rw-r--r--sources/gcc-uclibc-3.3-100-conf.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/sources/gcc-uclibc-3.3-100-conf.patch b/sources/gcc-uclibc-3.3-100-conf.patch
index e09c42dc8..2f8391255 100644
--- a/sources/gcc-uclibc-3.3-100-conf.patch
+++ b/sources/gcc-uclibc-3.3-100-conf.patch
@@ -1773,6 +1773,19 @@ diff -urN gcc-3.3.2/libstdc++-v3/configure.in gcc-3.3.2-uClibc/libstdc++-v3/conf
*-linux*)
os_include_dir="os/gnu-linux"
AC_CHECK_HEADERS([nan.h ieeefp.h endian.h sys/isa_defs.h \
+diff -urN gcc-3.3.2/libstdc++-v3/configure.target gcc-3.3.2-uClibc/libstdc++-v3/configure.target
+--- gcc-3.3.2/libstdc++-v3/configure.target 2004-01-24 12:02:59.000000000 -0600
++++ gcc-3.3.2-uClibc/libstdc++-v3/configure.target 2004-01-24 12:05:30.000000000 -0600
+@@ -133,6 +133,9 @@
+ freebsd*)
+ os_include_dir="os/bsd/freebsd"
+ ;;
++ linux-uclibc*)
++ os_include_dir="os/uclibc"
++ ;;
+ gnu* | linux*)
+ os_include_dir="os/gnu-linux"
+ ;;
diff -urN gcc-3.3.2/libstdc++-v3/include/c_std/std_cstdlib.h gcc-3.3.2-uClibc/libstdc++-v3/include/c_std/std_cstdlib.h
--- gcc-3.3.2/libstdc++-v3/include/c_std/std_cstdlib.h 2003-04-18 05:08:05.000000000 -0500
+++ gcc-3.3.2-uClibc/libstdc++-v3/include/c_std/std_cstdlib.h 2004-01-06 18:22:00.000000000 -0600