summaryrefslogtreecommitdiffstats
path: root/sources/gcc-uclibc-3.3-120-softfloat.patch
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-01-16 19:08:39 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-01-16 19:08:39 +0000
commit93e576b799bacbe419b1c442d116b41734f8d03b (patch)
tree649a06c045b54355eb421b7d1f71c80038b5f419 /sources/gcc-uclibc-3.3-120-softfloat.patch
parent2d472b2334f683eff884f3e9c8e63f0c02bfa6b7 (diff)
downloadbuildroot-novena-93e576b799bacbe419b1c442d116b41734f8d03b.tar.gz
buildroot-novena-93e576b799bacbe419b1c442d116b41734f8d03b.zip
Get soft float working for gcc 3.3.2. Support for arm, mips, mipsel, powerpc.
Diffstat (limited to 'sources/gcc-uclibc-3.3-120-softfloat.patch')
-rw-r--r--sources/gcc-uclibc-3.3-120-softfloat.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/sources/gcc-uclibc-3.3-120-softfloat.patch b/sources/gcc-uclibc-3.3-120-softfloat.patch
new file mode 100644
index 000000000..f2431896c
--- /dev/null
+++ b/sources/gcc-uclibc-3.3-120-softfloat.patch
@@ -0,0 +1,14 @@
+--- gcc-3.3.2-old/configure.in 2003-08-09 01:57:21.000000000 -0500
++++ gcc-3.3.2/configure.in 2004-01-15 12:46:29.000000000 -0600
+@@ -1418,6 +1418,11 @@
+ fi
+
+ FLAGS_FOR_TARGET=
++case " $targargs " in
++ *" --nfp "* | *" --without-float "*)
++ FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -msoft-float'
++ ;;
++esac
+ case " $target_configdirs " in
+ *" newlib "*)
+ case " $targargs " in