summaryrefslogtreecommitdiffstats
path: root/project/project.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-09-05 15:49:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-09-16 20:28:25 +0200
commit397fe5cc0b091c997794d755d27a72848ad210ea (patch)
treec4884e9bb5c32bca28cf07f3ebf3a643bfab4e72 /project/project.mk
parentb3ee84e4072279fda52c18fb7b3aa76a6b873c2d (diff)
downloadbuildroot-novena-397fe5cc0b091c997794d755d27a72848ad210ea.tar.gz
buildroot-novena-397fe5cc0b091c997794d755d27a72848ad210ea.zip
Remove the "project" feature
The "project" feature was designed to allow to several projects to be built inside the same Buildroot source tree and allowing the toolchain and non-configurable packages to be shared between the different projects on the same architecture. While being interesting in theory, this feature adds a level of complexity to Buildroot, both from an user perspective and from a developer perspective, while one of the main Buildroot strengh is to be simple. Moreover, this feature is only seldomly used by our users. From a user-level perspective, this for example allows to remove the project_build_ARCH directory, which was very confusing. The autotools-stamps directory is also removed, since these stamps are back at their normal location. Description of the changes involved : * project/, directory removed * Makefile - Don't include project/Makefile.in and project/project.mk anymore - Grab a copy of the contents of project/Makefile.in at the location it was imported, but remove the definition related to PROJECT_BUILD_DIR. The TARGET_DIR is now in $(BUILD_DIR)/target_dir - Remove the creation/removal of the $(PROJECT_BUILD_DIR) and $(PROJECT_BUILD_DIR)/autotools-stamps directories - Don't make world depends on target-host-info. This target was defined by project/project.mk to customize /etc/issue, /etc/hostname and create /etc/br-version depending on the project definitions. We can of course imagine re-adding such a feature later. - Replace PROJECT_BUILD_DIR by BUILD_DIR everywhere - Remove the update, log and lognr.$(PROJECT) target, they were specific to the project feature. * package/Makefile.autotools.in - Replace PROJECT_BUILD_DIR by BUILD_DIR for the location of the configure cache - Move the INSTALL_TARGET and HOOK_POST_INSTALL stamps to the same directory as the other stamps (i.e, in the package directory). * package/Makefile.in - Replace PROJECT_BUILD_DIR by BUILD_DIR for the location of the configure cache * package/at/at.mk, package/busybox/busybox.mk, package/busybox/initramfs.mk, package/customize/customize.mk, package/linux-fusion/linux-fusion.mk, package/ltp-testsuite/ltp-testsuite.mk, package/nfs-utils/nfs-utils.mk, target/cpio/cpioroot.mk, target/cramfs/cramfs.mk, target/device/Atmel/DataFlashBoot/DataflashBoot.mk, target/device/Atmel/Makefile.in, target/device/Atmel/at91bootstrap/at91bootstrap.mk, target/device/KwikByte/Makefile.in, target/ext2/ext2root.mk, target/initramfs/initramfs.mk, target/iso9660/iso9660.mk, target/jffs2/jffs2root.mk, target/linux/Makefile.in, target/romfs/romfs.mk, target/squashfs/squashfsroot.mk, target/tar/tarroot.mk, target/ubifs/ubifsroot.mk - Replace PROJECT_BUILD_DIR by BUILD_DIR * target/device/Config.in - Do not include project/Config.in anymore * target/linux/Makefile.in.advanced - Replace PROJECT_BUILD_DIR by BUILD_DIR - Store the stamps file in $(STAMP_DIR) instead of $(PROJECT_BUILD_DIR)/autotools-stamps * target/u-boot/Makefile.in - Replace PROJECT_BUILD_DIR by BUILD_DIR - Remove $(PROJECT) from the U-Boot target binary name - Remove the insertion in the configuration of the project name as the hostname - The u-boot-autoscript target now generates $(U_BOOT_AUTOSCRIPT).img instead of $(U_BOOT_AUTOSCRIPT).$(PROJECT) * toolchain/gcc/gcc-uclibc-3.x.mk toolchain/gcc/gcc-uclibc-4.x.mk - Move the stamps files to $(STAMP_DIR) Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'project/project.mk')
-rw-r--r--project/project.mk52
1 files changed, 0 insertions, 52 deletions
diff --git a/project/project.mk b/project/project.mk
deleted file mode 100644
index 3074eff48..000000000
--- a/project/project.mk
+++ /dev/null
@@ -1,52 +0,0 @@
-PROJECT_FILE:=$(LOCAL)/$(PROJECT)/$(PROJECT).config
-
-
-.PHONY: target-host-info saveconfig getconfig
-
-target-host-info: $(TARGET_DIR)/etc/issue $(TARGET_DIR)/etc/hostname $(TARGET_DIR)/etc/br-version
-
-$(TARGET_DIR)/etc/issue: .config
- mkdir -p $(TARGET_DIR)/etc
- echo "" > $@
- echo "" >> $@
- echo "$(BANNER)" >> $@
-
-$(TARGET_DIR)/etc/hostname: .config
- mkdir -p $(TARGET_DIR)/etc
- echo "$(TARGET_HOSTNAME)" > $@
-
-$(TARGET_DIR)/etc/br-version: .config
- mkdir -p $(TARGET_DIR)/etc
- echo $(BR2_VERSION)$(shell $(TOPDIR)/scripts/setlocalversion) >$@
-
-saveconfig:
- mkdir -p $(LOCAL)/$(PROJECT)
- -cp .config $(PROJECT_FILE)
- if [ -f $(LINUX26_DIR)/.config ]; then \
- cp $(LINUX26_DIR)/.config \
- $(LOCAL)/$(PROJECT)/linux-$(LINUX26_VERSION).config; \
- $(SED) '/BR2_PACKAGE_LINUX_KCONFIG/d' $(PROJECT_FILE); \
- echo "BR2_PACKAGE_LINUX_KCONFIG=\"$(LOCAL)/$(PROJECT)/linux-$(LINUX26_VERSION).config\"" >> $(PROJECT_FILE); \
- $(SED) '/BR2_BOARD_PATH/d' $(PROJECT_FILE); \
- echo "BR2_BOARD_PATH=\"$(LOCAL)/$(PROJECT)\"" >> $(PROJECT_FILE); \
- fi
- if [ -f $(BUSYBOX_DIR)/.config ]; then \
- cp $(BUSYBOX_DIR)/.config \
- $(LOCAL)/$(PROJECT)/busybox-$(BUSYBOX_VERSION).config; \
- $(SED) '/BR2_PACKAGE_BUSYBOX_CONFIG/d' $(PROJECT_FILE); \
- echo "BR2_PACKAGE_BUSYBOX_CONFIG=\"$(LOCAL)/$(PROJECT)/busybox-$(BUSYBOX_VERSION).config\"" >> $(PROJECT_FILE); \
- fi
- if [ -f $(UCLIBC_DIR)/.config ]; then \
- cp $(UCLIBC_DIR)/.config \
- $(LOCAL)/$(PROJECT)/uclibc-$(UCLIBC_VER).config; \
- $(SED) '/BR2_UCLIBC_CONFIG/d' $(PROJECT_FILE); \
- echo "BR2_UCLIBC_CONFIG=\"$(LOCAL)/$(PROJECT)/uclibc-$(UCLIBC_VER).config\"" >> $(PROJECT_FILE); \
- fi
- if [ -f $(UBOOT_DIR)/include/configs/$(PROJECT).h ]; then \
- mkdir -p $(LOCAL)/$(PROJECT)/u-boot; \
- cp $(UBOOT_DIR)/include/configs/$(PROJECT).h \
- $(LOCAL)/$(PROJECT)/u-boot/$(PROJECT).h; \
- fi
-
-getconfig:
- -cp $(LOCAL)/$(PROJECT)/$(PROJECT).config .config