summaryrefslogtreecommitdiffstats
path: root/package/wireshark/wireshark.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-03-01 11:11:24 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-01 11:11:24 +0100
commitca79d2393519759d3fbe84472ab8bfa359c08592 (patch)
tree3d7ba19e17cc066b327ae62d004164a61ba39d9b /package/wireshark/wireshark.mk
parent37d2ab569d83845a86b980bf4e27e27755294538 (diff)
parent1942836999ad64b7a84bd95a6bd1f5c75b81bf45 (diff)
downloadbuildroot-novena-ca79d2393519759d3fbe84472ab8bfa359c08592.tar.gz
buildroot-novena-ca79d2393519759d3fbe84472ab8bfa359c08592.zip
Merge branch 'next'
Diffstat (limited to 'package/wireshark/wireshark.mk')
-rw-r--r--package/wireshark/wireshark.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/wireshark/wireshark.mk b/package/wireshark/wireshark.mk
new file mode 100644
index 000000000..2e89987de
--- /dev/null
+++ b/package/wireshark/wireshark.mk
@@ -0,0 +1,23 @@
+#############################################################
+#
+# wireshark
+#
+#############################################################
+
+WIRESHARK_VERSION = 1.8.5
+WIRESHARK_SOURCE = wireshark-$(WIRESHARK_VERSION).tar.bz2
+WIRESHARK_SITE = http://www.wireshark.org/download/src/all-versions
+WIRESHARK_LICENSE = wireshark license
+WIRESHARK_LICENSE_FILES = COPYING
+WIRESHARK_DEPENDENCIES = libpcap libgcrypt libglib2
+WIRESHARK_AUTORECONF = YES
+WIRESHARK_CONF_ENV = LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config \
+ ac_cv_path_PCAP_CONFIG=$(STAGING_DIR)/usr/bin/pcap-config
+
+# wireshark adds -I$includedir to CFLAGS, causing host/target headers mixup.
+# Work around it by pointing includedir at staging
+WIRESHARK_CONF_OPT = --disable-wireshark --without-krb5 --disable-usr-local \
+ --enable-static=no --with-gnutls=no \
+ --includedir=$(STAGING_DIR)/usr/include
+
+$(eval $(call autotools-package))