aboutsummaryrefslogtreecommitdiffstats
path: root/package/vtun/vtund.rc.debian-3.0.2
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-02-17 13:22:31 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-22 23:44:11 +0100
commit2b36d80c63afae74bf759f27e3eecf9e1f394e77 (patch)
tree1b282846aadc0e41510f6fbd35dbf466ef4d3a2c /package/vtun/vtund.rc.debian-3.0.2
parent54b2bad158fd10c0514fe37832108c30e0c4a291 (diff)
downloadbuildroot-novena-2b36d80c63afae74bf759f27e3eecf9e1f394e77.tar.gz
buildroot-novena-2b36d80c63afae74bf759f27e3eecf9e1f394e77.zip
package/vtun: update to 3.0.3
Against all odds, vtun had a new release sometime last year. Still, the code needs patching: - the existing patch to fix installation has been refreshed - the existing patch to fix blowfish header location has been replaced (see below) - configure looks in hard-coded, host paths (eg. /usr/include) without any consideration for scross-compilation --> new patch - configure.in does not even pass an autoreconf without a bit of love first (it's written in an ancient dialect that autoreconf does no longer recognise) --> new patch Remove obsolete, unused, bit-rotting scripts and warning. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/vtun/vtund.rc.debian-3.0.2')
-rw-r--r--package/vtun/vtund.rc.debian-3.0.261
1 files changed, 0 insertions, 61 deletions
diff --git a/package/vtun/vtund.rc.debian-3.0.2 b/package/vtun/vtund.rc.debian-3.0.2
deleted file mode 100644
index 5158663f1..000000000
--- a/package/vtun/vtund.rc.debian-3.0.2
+++ /dev/null
@@ -1,61 +0,0 @@
-#! /bin/sh
-#
-# submitted by Morgon Kanter
-#
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-DAEMON=/usr/sbin/vtund
-CONFFILE=/etc/vtund-start.conf
-PIDPREFIX=/var/run/vtund
-
-test -f $DAEMON || exit 0
-
-case "$1" in
- start)
- # find all the defined tunnels
- egrep -v '^[:space:]*(#.*)?$' $CONFFILE | while true;
- do
- read i
- # no more lines available? done, then.
- if [ $? != 0 ] ; then break; fi
- SARGS=`echo $i|sed -ne 's/--server--\s*/-s -P /p'`;
- if [ -n "$SARGS" ];
- then
- echo "Starting vtund server."
- start-stop-daemon --start --exec $DAEMON --pidfile $PIDPREFIX.pid -- $SARGS;
- else
- # split args into host and rest
- HOST=`echo $i|cut -f 1 -d " "`;
- TARGET=`echo $i|cut -f 2 -d " "`;
- echo "Starting vtund client $HOST to $TARGET.";
- start-stop-daemon --start --exec $DAEMON --pidfile $PIDPREFIX.$HOST.pid -- $i;
-
- fi
- done
- ;;
- stop)
- echo "Stopping vtund.";
- for i in $PIDPREFIX*;
- do
- start-stop-daemon --stop --pidfile $i;
- rm -f $i;
- done
- ;;
- reload|force-reload)
- echo "Reloading vtund.";
- for i in $PIDPREFIX*;
- do
- start-stop-daemon --stop --signal 1 --pidfile $i;
- done
- ;;
- restart)
- $0 stop
- sleep 1;
- $0 start
- ;;
- *)
- echo "Usage: $0 {start|stop|restart|reload|force-reload}" >&2
- exit 1
- ;;
-esac
-exit 0