aboutsummaryrefslogtreecommitdiffstats
path: root/package/vtun/vtund.rc.debian-2.6
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-02-17 13:22:31 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-22 23:44:11 +0100
commit2b36d80c63afae74bf759f27e3eecf9e1f394e77 (patch)
tree1b282846aadc0e41510f6fbd35dbf466ef4d3a2c /package/vtun/vtund.rc.debian-2.6
parent54b2bad158fd10c0514fe37832108c30e0c4a291 (diff)
downloadbuildroot-novena-2b36d80c63afae74bf759f27e3eecf9e1f394e77.tar.gz
buildroot-novena-2b36d80c63afae74bf759f27e3eecf9e1f394e77.zip
package/vtun: update to 3.0.3
Against all odds, vtun had a new release sometime last year. Still, the code needs patching: - the existing patch to fix installation has been refreshed - the existing patch to fix blowfish header location has been replaced (see below) - configure looks in hard-coded, host paths (eg. /usr/include) without any consideration for scross-compilation --> new patch - configure.in does not even pass an autoreconf without a bit of love first (it's written in an ancient dialect that autoreconf does no longer recognise) --> new patch Remove obsolete, unused, bit-rotting scripts and warning. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/vtun/vtund.rc.debian-2.6')
-rw-r--r--package/vtun/vtund.rc.debian-2.650
1 files changed, 0 insertions, 50 deletions
diff --git a/package/vtun/vtund.rc.debian-2.6 b/package/vtun/vtund.rc.debian-2.6
deleted file mode 100644
index eb8226e9c..000000000
--- a/package/vtun/vtund.rc.debian-2.6
+++ /dev/null
@@ -1,50 +0,0 @@
-#! /bin/sh
-#
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-DAEMON=/usr/sbin/vtund
-CONFFILE=/etc/vtund-start.conf
-PIDPREFIX=/var/run/vtund
-
-test -f $DAEMON || exit 0
-
-case "$1" in
- start)
- # find all the defined tunnels
- egrep -v '^[:space:]*(#.*)?$' $CONFFILE | while true;
- do
- read i
- # no more lines available? done, then.
- if [ $? != 0 ] ; then break; fi
- SARGS=`echo $i|sed -ne 's/--server--\s*/-s -P /p'`;
- if [ -n "$SARGS" ];
- then
- echo "Starting vtund server."
- start-stop-daemon -S -x $DAEMON -- $SARGS;
- else
- # split args into host and rest
- HOST=`echo $i|cut -f 1 -d " "`;
- TARGET=`echo $i|cut -f 2 -d " "`;
- echo "Starting vtund client $HOST to $TARGET.";
- start-stop-daemon -S -x $DAEMON -- $i;
-
- fi
- done
- ;;
- stop)
- echo "Stopping vtund.";
- start-stop-daemon -K -x vtund;
- ;;
-
- restart|reload|force-reload)
- $0 stop
- sleep 1;
- $0 start
- ;;
- *)
- echo "Usage: $0 {start|stop|restart|reload|force-reload}" >&2
- exit 1
- ;;
-esac
-exit 0
-