summaryrefslogtreecommitdiffstats
path: root/package/uboot-tools/uboot-tools-hostcflags-override-fix.patch
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-01-04 10:22:47 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-04 21:26:58 +0100
commit150564a8bb82f5577362030b8354aaa68e08a0ea (patch)
tree9267b125b205109bf467a2c71ff646b78fe04811 /package/uboot-tools/uboot-tools-hostcflags-override-fix.patch
parentb16f37b03c383f70c6cc50582f6b3ee4cf5aa037 (diff)
downloadbuildroot-novena-150564a8bb82f5577362030b8354aaa68e08a0ea.tar.gz
buildroot-novena-150564a8bb82f5577362030b8354aaa68e08a0ea.zip
uboot-tools: bump to version 2012.10
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/uboot-tools/uboot-tools-hostcflags-override-fix.patch')
-rw-r--r--package/uboot-tools/uboot-tools-hostcflags-override-fix.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/uboot-tools/uboot-tools-hostcflags-override-fix.patch b/package/uboot-tools/uboot-tools-hostcflags-override-fix.patch
new file mode 100644
index 000000000..0202eda9b
--- /dev/null
+++ b/package/uboot-tools/uboot-tools-hostcflags-override-fix.patch
@@ -0,0 +1,29 @@
+[PATCH] Fix tools build with custom HOSTCFLAGS
+
+We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
+overridden on the cmdline.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ config.mk | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+Index: u-boot-2011.03/config.mk
+===================================================================
+--- u-boot-2011.03.orig/config.mk
++++ u-boot-2011.03/config.mk
+@@ -46,10 +46,12 @@
+
+ #########################################################################
+
+-HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
+- $(HOSTCPPFLAGS)
++HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
+ HOSTSTRIP = strip
+
++# append CPPFLAGS even if CFLAGS has been overridden on cmdline
++override HOSTCFLAGS += $(HOSTCPPFLAGS)
++
+ #
+ # Mac OS X / Darwin's C preprocessor is Apple specific. It
+ # generates numerous errors and warnings. We want to bypass it