summaryrefslogtreecommitdiffstats
path: root/package/uboot-mkimage/uboot-mkimage.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-18 15:22:13 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-18 15:27:52 +0200
commit7a2fa1f8db5c2e627a4b939862af5f938fcfc359 (patch)
tree493a2520b34487f2c983b69a2f6775784d6ad9cf /package/uboot-mkimage/uboot-mkimage.mk
parent1dfc43cced8d30984687950beca6448203fb576d (diff)
downloadbuildroot-novena-7a2fa1f8db5c2e627a4b939862af5f938fcfc359.tar.gz
buildroot-novena-7a2fa1f8db5c2e627a4b939862af5f938fcfc359.zip
uboot-tools: add fw_printenv, rename to uboot-tools
Move fw_printenv / fw_setenv options from the uboot bootloader build to the uboot-mkimage package, and rename it to uboot-tools. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/uboot-mkimage/uboot-mkimage.mk')
-rw-r--r--package/uboot-mkimage/uboot-mkimage.mk31
1 files changed, 0 insertions, 31 deletions
diff --git a/package/uboot-mkimage/uboot-mkimage.mk b/package/uboot-mkimage/uboot-mkimage.mk
deleted file mode 100644
index d8a8fbbe9..000000000
--- a/package/uboot-mkimage/uboot-mkimage.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-UBOOT_MKIMAGE_VERSION = 2011.03
-UBOOT_MKIMAGE_SOURCE = u-boot-$(UBOOT_MKIMAGE_VERSION).tar.bz2
-UBOOT_MKIMAGE_SITE = ftp://ftp.denx.de/pub/u-boot
-
-define UBOOT_MKIMAGE_BUILD_CMDS
- $(MAKE) -C $(@D) \
- HOSTCC="$(TARGET_CC)" \
- HOSTCFLAGS="$(TARGET_CFLAGS)" \
- HOSTLDFLAGS="$(TARGET_LDFLAGS)" \
- HOSTSTRIP=true \
- tools
-endef
-
-define UBOOT_MKIMAGE_INSTALL_CMDS
- install -m 0755 -D $(@D)/tools/mkimage $(TARGET_DIR)/usr/bin
-endef
-
-define HOST_UBOOT_MKIMAGE_BUILD_CMDS
- $(MAKE) -C $(@D) \
- HOSTCC="$(HOSTCC)" \
- HOSTCFLAGS="$(HOST_CFLAGS)" \
- HOSTLDFLAGS="$(HOST_LDFLAGS)" \
- tools
-endef
-
-define HOST_UBOOT_MKIMAGE_INSTALL_CMDS
- install -m 0755 -D $(@D)/tools/mkimage $(HOST_DIR)/usr/bin
-endef
-
-$(eval $(call GENTARGETS,package,uboot-mkimage))
-$(eval $(call GENTARGETS,package,uboot-mkimage,host))