summaryrefslogtreecommitdiffstats
path: root/package/tvheadend/tvheadend-no-auto-download-dvbscans.patch
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2012-12-28 12:37:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-28 23:40:26 +0100
commit14989d0be59762a354e7c5c15a2eeb4826d8040b (patch)
treef47c0c5725cecb619552786fafad18d9fe5c924b /package/tvheadend/tvheadend-no-auto-download-dvbscans.patch
parent6904b0ea954c22f3efb9619dc4a7b793fe985547 (diff)
downloadbuildroot-novena-14989d0be59762a354e7c5c15a2eeb4826d8040b.tar.gz
buildroot-novena-14989d0be59762a354e7c5c15a2eeb4826d8040b.zip
package/tvheadend: new package
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/tvheadend/tvheadend-no-auto-download-dvbscans.patch')
-rw-r--r--package/tvheadend/tvheadend-no-auto-download-dvbscans.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/package/tvheadend/tvheadend-no-auto-download-dvbscans.patch b/package/tvheadend/tvheadend-no-auto-download-dvbscans.patch
new file mode 100644
index 000000000..50bc4b69d
--- /dev/null
+++ b/package/tvheadend/tvheadend-no-auto-download-dvbscans.patch
@@ -0,0 +1,60 @@
+Do not download transponder data as part of the build
+
+If dvb-scan is enabled, tvheadend will download the transponders data
+from the dvb-apps package. This does not play well with buildroot.
+
+Instead, we rely on the dvb-apps package to install those files, so
+it is no longer needed to install those as part of tvheadend.
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+
+diff -durN tvheadend-v3.3.orig//configure tvheadend-v3.3/configure
+--- tvheadend-v3.3.orig//configure 2012-09-25 15:32:31.000000000 +0200
++++ tvheadend-v3.3/configure 2012-12-28 17:17:23.580253413 +0100
+@@ -96,13 +96,14 @@
+ #
+ # DVB scan
+ #
+-if enabled linuxdvb && enabled dvbscan; then
+- if [ ! -d ${ROOTDIR}/data/dvb-scan ]; then
+- echo -n "Fetching dvb-scan files... "
+- ${ROOTDIR}/support/getmuxlist &> /dev/null || die "Failed to fetch dvb-scan files (use --disable-dvbscan to skip)"
+- echo "done"
+- fi
+-fi
++# For buildroot, we already installed those files via the dvb-apps package
++#if enabled linuxdvb && enabled dvbscan; then
++# if [ ! -d ${ROOTDIR}/data/dvb-scan ]; then
++# echo -n "Fetching dvb-scan files... "
++# ${ROOTDIR}/support/getmuxlist &> /dev/null || die "Failed to fetch dvb-scan files (use --disable-dvbscan to skip)"
++# echo "done"
++# fi
++#fi
+
+ # ###########################################################################
+ # Write config
+diff -durN tvheadend-v3.3.orig//Makefile tvheadend-v3.3/Makefile
+--- tvheadend-v3.3.orig//Makefile 2012-09-25 15:32:31.000000000 +0200
++++ tvheadend-v3.3/Makefile 2012-12-28 17:17:47.573497346 +0100
+@@ -180,7 +180,7 @@
+ SRCS-${CONFIG_BUNDLE} += bundle.c
+ BUNDLES-yes += docs/html docs/docresources src/webui/static
+ BUNDLES-yes += data/conf
+-BUNDLES-${CONFIG_DVBSCAN} += data/dvb-scan
++#BUNDLES-${CONFIG_DVBSCAN} += data/dvb-scan
+ BUNDLES = $(BUNDLES-yes)
+
+ #
+diff -durN tvheadend-v3.3.orig//support/posix.mk tvheadend-v3.3/support/posix.mk
+--- tvheadend-v3.3.orig//support/posix.mk 2012-09-25 15:32:31.000000000 +0200
++++ tvheadend-v3.3/support/posix.mk 2012-12-28 17:19:28.903121722 +0100
+@@ -12,7 +12,8 @@
+ mkdir -p ${DESTDIR}${datadir}/tvheadend/$$bundle ;\
+ cp -r $$bundle/* ${DESTDIR}${datadir}/tvheadend/$$bundle ;\
+ done
+-
++ mkdir -p ${DESTDIR}${datadir}/tvheadend/data
++ ln -s /usr/share/dvb-apps/scan ${DESTDIR}${datadir}/tvheadend/data/dvb-scan
+
+ uninstall:
+ rm -f ${DESTDIR}${bindir)/tvheadend