summaryrefslogtreecommitdiffstats
path: root/package/supervisor/supervisor.mk
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2012-08-11 17:12:06 +1000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-08-11 22:59:12 +0200
commit380ff787d95f9fa36a73503fd3ac6d5c40a5e6bc (patch)
tree3137eefcf78713cb6e5523c6b862d1307584759c /package/supervisor/supervisor.mk
parent1ff74a535d9c5e7e7f996eb9b8d8f83f8af44f1e (diff)
downloadbuildroot-novena-380ff787d95f9fa36a73503fd3ac6d5c40a5e6bc.tar.gz
buildroot-novena-380ff787d95f9fa36a73503fd3ac6d5c40a5e6bc.zip
supervisor: new package
[thomas.petazzoni@free-electrons.com: Fixup indentation of Config.in file. Add 'depends on BR2_PACKAGE_PYTHON' so that the package does not appear when the Python interpreter is not enabled. Add license files information, but not the license tag: the package includes software under multiple licenses.] Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/supervisor/supervisor.mk')
-rw-r--r--package/supervisor/supervisor.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/supervisor/supervisor.mk b/package/supervisor/supervisor.mk
new file mode 100644
index 000000000..26afff35f
--- /dev/null
+++ b/package/supervisor/supervisor.mk
@@ -0,0 +1,26 @@
+#############################################################
+#
+# python-supervisor
+#
+#############################################################
+
+SUPERVISOR_VERSION = 3.0a12
+SUPERVISOR_SOURCE = supervisor-$(SUPERVISOR_VERSION).tar.gz
+SUPERVISOR_SITE = http://pypi.python.org/packages/source/s/supervisor/
+SUPERVISOR_LICENSE_FILES = LICENSES.txt
+
+SUPERVISOR_DEPENDENCIES = python host-python-setuptools
+
+define SUPERVISOR_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define SUPERVISOR_INSTALL_TARGET_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=/usr --root=$(TARGET_DIR))
+ sed -i '1s|#!.*python.*|#!/usr/bin/env python|' $(TARGET_DIR)/usr/bin/{echo_supervisord_conf,pidproxy,supervisorctl,supervisord}
+ $(INSTALL) -d -m 755 $(TARGET_DIR)/etc/supervisor.d
+ $(INSTALL) -D -m 644 package/supervisor/supervisord.conf $(TARGET_DIR)/etc/supervisord.conf
+ $(INSTALL) -m 755 package/supervisor/S99supervisord $(TARGET_DIR)/etc/init.d/S99supervisord
+endef
+
+$(eval $(generic-package))