aboutsummaryrefslogtreecommitdiffstats
path: root/package/spice/spice.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2012-12-16 06:56:16 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-16 21:34:13 +0100
commita872142c2f25761cbcfe024d4b9f0072f2639cea (patch)
tree6d0228543a70fed845373bb79d6cb1680b854da2 /package/spice/spice.mk
parent93d4e38450639aef401adfcc2c4e412efaef3da9 (diff)
downloadbuildroot-novena-a872142c2f25761cbcfe024d4b9f0072f2639cea.tar.gz
buildroot-novena-a872142c2f25761cbcfe024d4b9f0072f2639cea.zip
package/spice: enable client
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/spice/spice.mk')
-rw-r--r--package/spice/spice.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/spice/spice.mk b/package/spice/spice.mk
index 2752b8af7..2f7fc20d1 100644
--- a/package/spice/spice.mk
+++ b/package/spice/spice.mk
@@ -26,12 +26,18 @@ SPICE_CONF_OPT = \
--disable-gui \
--disable-opengl \
--disable-smartcard \
- --disable-client \
--disable-automated-tests \
--without-sasl \
SPICE_DEPENDENCIES += host-pkgconf
+ifeq ($(BR2_PACKAGE_SPICE_CLIENT),y)
+SPICE_CONF_OPT += --enable-client
+SPICE_DEPENDENCIES += xlib_libXfixes xlib_libXrandr
+else
+SPICE_CONF_OPT += --disable-client
+endif
+
SPICE_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
SPICE_MAKE_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages