summaryrefslogtreecommitdiffstats
path: root/package/rpi-userland/rpi-userland.mk
diff options
context:
space:
mode:
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>2013-01-06 10:56:21 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-06 23:01:11 +0100
commitabb68f6fa79612830b65ba591534cdd0cb898f68 (patch)
tree079f3e749c655dc72c619f2cac77e5f3e4f7c243 /package/rpi-userland/rpi-userland.mk
parent8bc34206c2ed03f24db1ed196a2fb7c5015acfb8 (diff)
downloadbuildroot-novena-abb68f6fa79612830b65ba591534cdd0cb898f68.tar.gz
buildroot-novena-abb68f6fa79612830b65ba591534cdd0cb898f68.zip
rpi-userland: new package
Introducing a package to build the userland part of the Raspberry, needed by anyone who would want to build a rootfs for a RaspberryPi. [Peter: fixup Config.in (rename, move, arm dep, comment, white space)] Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/rpi-userland/rpi-userland.mk')
-rw-r--r--package/rpi-userland/rpi-userland.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/rpi-userland/rpi-userland.mk b/package/rpi-userland/rpi-userland.mk
new file mode 100644
index 000000000..ece37d488
--- /dev/null
+++ b/package/rpi-userland/rpi-userland.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# rpi-userland
+#
+#############################################################
+
+RPI_USERLAND_VERSION = 9852ce28826889e50c4d6786b942f51bccccac54
+RPI_USERLAND_SITE = http://github.com/raspberrypi/userland/tarball/master
+RPI_USERLAND_LICENSE = BSD-3c
+RPI_USERLAND_LICENSE_FILE = LICENCE
+RPI_USERLAND_INSTALL_STAGING = YES
+RPI_USERLAND_CONF_OPT = -DVMCS_INSTALL_PREFIX=/usr
+
+define RPI_USERLAND_POST_TARGET_CLEANUP
+ rm -Rf $(TARGET_DIR)/usr/src
+endef
+
+RPI_USERLAND_POST_INSTALL_TARGET_HOOKS += RPI_USERLAND_POST_TARGET_CLEANUP
+
+$(eval $(cmake-package))