summaryrefslogtreecommitdiffstats
path: root/package/qt5/qt5base/qt5base.mk
diff options
context:
space:
mode:
authorFloris Bos <bos@je-eigen-domein.nl>2013-03-19 09:29:40 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-19 22:41:39 +0100
commit6cd7b60f8bd2ad827028e3a82d2f62cf63831a99 (patch)
treeb9ac8807b8e6ee88335a85082e936a8e00c11586 /package/qt5/qt5base/qt5base.mk
parent53fbd8a7c529ba307f6d693ceb1f42696cdf05d9 (diff)
downloadbuildroot-novena-6cd7b60f8bd2ad827028e3a82d2f62cf63831a99.tar.gz
buildroot-novena-6cd7b60f8bd2ad827028e3a82d2f62cf63831a99.zip
qt5base: add rPi EGL glue code
When the rpi-userland package is selected, assume we are targetting the Raspberry Pi, and add the right platform glue code when building the Qt5 EGLFS plugin. Signed-off-by: Floris Bos <bos@je-eigen-domein.nl> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt5/qt5base/qt5base.mk')
-rw-r--r--package/qt5/qt5base/qt5base.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index ac63e9814..3b4c007a0 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -75,6 +75,10 @@ endif
ifeq ($(BR2_PACKAGE_QT5BASE_EGLFS),y)
QT5BASE_CONFIGURE_OPTS += -opengl es2 -eglfs
QT5BASE_DEPENDENCIES += libgles libegl
+ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
+QT5BASE_EGLFS_PLATFORM_HOOKS_SOURCES = \
+ $(@D)/mkspecs/devices/linux-rasp-pi-g++/qeglfshooks_pi.cpp
+endif
else
QT5BASE_CONFIGURE_OPTS += -no-opengl -no-eglfs
endif
@@ -125,6 +129,8 @@ define QT5BASE_CONFIGURE_CMDS
$(call QT5BASE_CONFIG_SET,CROSS_COMPILE,$(TARGET_CROSS))
$(call QT5BASE_CONFIG_SET,COMPILER_CFLAGS,$(TARGET_CFLAGS))
$(call QT5BASE_CONFIG_SET,COMPILER_CXXFLAGS,$(TARGET_CXXFLAGS))
+ $(call QT5BASE_CONFIG_SET,EGLFS_PLATFORM_HOOKS_SOURCES, \
+ $(QT5BASE_EGLFS_PLATFORM_HOOKS_SOURCES))
(cd $(@D); \
PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig" \