aboutsummaryrefslogtreecommitdiffstats
path: root/package/python3/python3-3.3-009-verbose-module-build.patch
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2012-11-07 05:01:21 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-08 00:10:23 +0100
commit03c4d57f1d9e2b0f516afdd7e7b3f082694d3c0a (patch)
tree6468647d08879169eaaf2bd2d61c64471f905b5a /package/python3/python3-3.3-009-verbose-module-build.patch
parenta32fa707e5d79c92908bb81142b00afe81a3e3e2 (diff)
downloadbuildroot-novena-03c4d57f1d9e2b0f516afdd7e7b3f082694d3c0a.tar.gz
buildroot-novena-03c4d57f1d9e2b0f516afdd7e7b3f082694d3c0a.zip
Add python3 package
[Peter: s/python/python3/] Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python3/python3-3.3-009-verbose-module-build.patch')
-rw-r--r--package/python3/python3-3.3-009-verbose-module-build.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/python3/python3-3.3-009-verbose-module-build.patch b/package/python3/python3-3.3-009-verbose-module-build.patch
new file mode 100644
index 000000000..60b6d797d
--- /dev/null
+++ b/package/python3/python3-3.3-009-verbose-module-build.patch
@@ -0,0 +1,26 @@
+Enables verbose output when building modules
+
+Patch borrowed from OpenBricks.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+---
+ Makefile.pre.in | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+Index: Python-3.3.0/Makefile.pre.in
+===================================================================
+--- Python-3.3.0.orig/Makefile.pre.in
++++ Python-3.3.0/Makefile.pre.in
+@@ -476,10 +476,9 @@
+
+ # Build the shared modules
+ sharedmods: $(BUILDPYTHON) pybuilddir.txt
+- case $$MAKEFLAGS in *s*) quiet=-q; esac; \
+ $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' \
+ CONFIG_ARGS="$(CONFIG_ARGS)" \
+- $(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
++ $(PYTHON_FOR_BUILD) $(srcdir)/setup.py build
+
+ # Build static library
+ # avoid long command lines, same as LIBRARY_OBJS